summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-11-20 08:21:44 +0000
committerHans de Graaff <graaff@gentoo.org>2011-11-20 08:21:44 +0000
commitbbce12581b85279ce8282ff22c6f5447d87de410 (patch)
tree1370f81c6b2b02316830f41dfa2cfbb01f84f8d0 /dev-ruby/multipart-post
parentsee if the doc target exists before we try to build it #348626 by Thomas Kahle (diff)
downloadgentoo-2-bbce12581b85279ce8282ff22c6f5447d87de410.tar.gz
gentoo-2-bbce12581b85279ce8282ff22c6f5447d87de410.tar.bz2
gentoo-2-bbce12581b85279ce8282ff22c6f5447d87de410.zip
Add missing file from upstream needed for tests with ruby19.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/multipart-post')
-rw-r--r--dev-ruby/multipart-post/ChangeLog6
-rw-r--r--dev-ruby/multipart-post/files/multibyte.txt1
-rw-r--r--dev-ruby/multipart-post/multipart-post-1.1.3.ebuild6
3 files changed, 11 insertions, 2 deletions
diff --git a/dev-ruby/multipart-post/ChangeLog b/dev-ruby/multipart-post/ChangeLog
index 5d933b7df6eb..ebfaa1a27c86 100644
--- a/dev-ruby/multipart-post/ChangeLog
+++ b/dev-ruby/multipart-post/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/multipart-post
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multipart-post/ChangeLog,v 1.6 2011/07/29 04:58:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multipart-post/ChangeLog,v 1.7 2011/11/20 08:21:44 graaff Exp $
+
+ 20 Nov 2011; Hans de Graaff <graaff@gentoo.org> multipart-post-1.1.3.ebuild,
+ +files/multibyte.txt:
+ Add missing file from upstream needed for tests with ruby19.
*multipart-post-1.1.3 (29 Jul 2011)
diff --git a/dev-ruby/multipart-post/files/multibyte.txt b/dev-ruby/multipart-post/files/multibyte.txt
new file mode 100644
index 000000000000..24a84b0457db
--- /dev/null
+++ b/dev-ruby/multipart-post/files/multibyte.txt
@@ -0,0 +1 @@
+ファイル
diff --git a/dev-ruby/multipart-post/multipart-post-1.1.3.ebuild b/dev-ruby/multipart-post/multipart-post-1.1.3.ebuild
index 7235c838e714..8d2e668c3a3d 100644
--- a/dev-ruby/multipart-post/multipart-post-1.1.3.ebuild
+++ b/dev-ruby/multipart-post/multipart-post-1.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multipart-post/multipart-post-1.1.3.ebuild,v 1.1 2011/07/29 04:58:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multipart-post/multipart-post-1.1.3.ebuild,v 1.2 2011/11/20 08:21:44 graaff Exp $
EAPI="2"
@@ -23,6 +23,10 @@ IUSE="test"
ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+all_ruby_prepare() {
+ cp "${FILESDIR}"/multibyte.txt test/ || die "Unable to copy multibyte.txt"
+}
+
each_ruby_test() {
${RUBY} -S testrb -Ilib test || die "Tests failed."
}