summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-18 13:38:14 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-18 13:38:14 +0000
commit9fd085e9faf909c6716b766a9b11cad2282b014b (patch)
tree4242415912173e077fcec4ccd657442df029cedf /dev-ruby/oauth2
parentPax-mark also unopkg.bin, crashes on my machine without. Without revbump. (diff)
downloadgentoo-2-9fd085e9faf909c6716b766a9b11cad2282b014b.tar.gz
gentoo-2-9fd085e9faf909c6716b766a9b11cad2282b014b.tar.bz2
gentoo-2-9fd085e9faf909c6716b766a9b11cad2282b014b.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/ChangeLog9
-rw-r--r--dev-ruby/oauth2/oauth2-0.5.2.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-ruby/oauth2/ChangeLog b/dev-ruby/oauth2/ChangeLog
index 148a668b496a..808d40e5050f 100644
--- a/dev-ruby/oauth2/ChangeLog
+++ b/dev-ruby/oauth2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/oauth2
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.11 2011/09/29 12:14:36 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.12 2012/04/18 13:38:14 graaff Exp $
+
+*oauth2-0.5.2 (18 Apr 2012)
+
+ 18 Apr 2012; Hans de Graaff <graaff@gentoo.org> +oauth2-0.5.2.ebuild:
+ Version bump.
*oauth2-0.5.1 (29 Sep 2011)
diff --git a/dev-ruby/oauth2/oauth2-0.5.2.ebuild b/dev-ruby/oauth2/oauth2-0.5.2.ebuild
new file mode 100644
index 000000000000..67b54a40e04c
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-0.5.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.5.2.ebuild,v 1.1 2012/04/18 13:38:14 graaff Exp $
+
+EAPI="2"
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
+HOMEPAGE="http://github.com/intridea/oauth2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/faraday-0.7.4 >=dev-ruby/multi_json-1.0.3"
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 dev-ruby/multi_xml )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e "/[Bb]undler/d" -e "/[Ss]imple[Cc]ov/d" spec/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S rspec spec || die
+}