summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-09-09 17:34:44 +0000
committerHans de Graaff <graaff@gentoo.org>2012-09-09 17:34:44 +0000
commiteab98f095fc97f5f44c7faa4db927ccfbd25a301 (patch)
tree56851d64a84de26d38f8ce167d12202ee582d0f6 /dev-ruby/oauth2
parentalpha/ia64/s390/sh/sparc stable wrt #431520 (diff)
downloadgentoo-2-eab98f095fc97f5f44c7faa4db927ccfbd25a301.tar.gz
gentoo-2-eab98f095fc97f5f44c7faa4db927ccfbd25a301.tar.bz2
gentoo-2-eab98f095fc97f5f44c7faa4db927ccfbd25a301.zip
Cleanup.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/ChangeLog6
-rw-r--r--dev-ruby/oauth2/oauth2-0.0.13.ebuild26
-rw-r--r--dev-ruby/oauth2/oauth2-0.4.1.ebuild35
-rw-r--r--dev-ruby/oauth2/oauth2-0.5.1.ebuild35
4 files changed, 5 insertions, 97 deletions
diff --git a/dev-ruby/oauth2/ChangeLog b/dev-ruby/oauth2/ChangeLog
index 53ecb72fb468..4455ced26786 100644
--- a/dev-ruby/oauth2/ChangeLog
+++ b/dev-ruby/oauth2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/oauth2
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.13 2012/09/09 17:28:24 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.14 2012/09/09 17:34:44 graaff Exp $
+
+ 09 Sep 2012; Hans de Graaff <graaff@gentoo.org> -oauth2-0.0.13.ebuild,
+ -oauth2-0.4.1.ebuild, -oauth2-0.5.1.ebuild:
+ Cleanup.
*oauth2-0.8.0 (09 Sep 2012)
diff --git a/dev-ruby/oauth2/oauth2-0.0.13.ebuild b/dev-ruby/oauth2/oauth2-0.0.13.ebuild
deleted file mode 100644
index 1c1774004142..000000000000
--- a/dev-ruby/oauth2/oauth2-0.0.13.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.0.13.ebuild,v 1.1 2010/08/22 13:16:46 flameeyes Exp $
-
-EAPI="2"
-
-USE_RUBY="ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-RUBY_FAKEGEM_TASK_DOC="rerdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGELOG.rdoc"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
-HOMEPAGE="http://github.com/intridea/oauth2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend "dev-ruby/faraday >=dev-ruby/multi_json-0.0.4"
-ruby_add_bdepend test ">=dev-ruby/rspec-1.2.9"
diff --git a/dev-ruby/oauth2/oauth2-0.4.1.ebuild b/dev-ruby/oauth2/oauth2-0.4.1.ebuild
deleted file mode 100644
index ee8c579b092b..000000000000
--- a/dev-ruby/oauth2/oauth2-0.4.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.4.1.ebuild,v 1.2 2011/07/24 20:09:44 tomka Exp $
-
-EAPI="2"
-
-USE_RUBY="ruby18 ruby19 jruby ree18"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="rerdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
-HOMEPAGE="http://github.com/intridea/oauth2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/faraday-0.6.1 >=dev-ruby/multi_json-0.0.5"
-ruby_add_bdepend test ">=dev-ruby/rspec-2.5.0:2"
-
-all_ruby_prepare() {
- rm Gemfile || die
- sed -i -e "/[Bb]undler/d" -e "/[Ss]imple[Cc]ov/d" spec/spec_helper.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -S rspec spec || die
-}
diff --git a/dev-ruby/oauth2/oauth2-0.5.1.ebuild b/dev-ruby/oauth2/oauth2-0.5.1.ebuild
deleted file mode 100644
index ddb5a40fce40..000000000000
--- a/dev-ruby/oauth2/oauth2-0.5.1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-0.5.1.ebuild,v 1.1 2011/09/29 12:14:36 graaff Exp $
-
-EAPI="2"
-
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
-HOMEPAGE="http://github.com/intridea/oauth2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/faraday-0.7.4 >=dev-ruby/multi_json-1.0.3"
-ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 dev-ruby/multi_xml )"
-
-all_ruby_prepare() {
- rm Gemfile || die
- sed -i -e "/[Bb]undler/d" -e "/[Ss]imple[Cc]ov/d" spec/helper.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -S rspec spec || die
-}