summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-12-01 15:47:29 +0000
committerHans de Graaff <graaff@gentoo.org>2012-12-01 15:47:29 +0000
commit3fca5b1f6265da9ac6fba16db63abc0b16e64426 (patch)
tree527eab53798c9749eca5e5aaa0ecac30f3c94b9c /dev-ruby/racc
parentAdded myself as maintainer (diff)
downloadgentoo-2-3fca5b1f6265da9ac6fba16db63abc0b16e64426.tar.gz
gentoo-2-3fca5b1f6265da9ac6fba16db63abc0b16e64426.tar.bz2
gentoo-2-3fca5b1f6265da9ac6fba16db63abc0b16e64426.zip
Version bump. Drop ree18 since tests are broken and ree18 will be masked shortly anyway.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/racc')
-rw-r--r--dev-ruby/racc/ChangeLog8
-rw-r--r--dev-ruby/racc/racc-1.4.9.ebuild90
2 files changed, 97 insertions, 1 deletions
diff --git a/dev-ruby/racc/ChangeLog b/dev-ruby/racc/ChangeLog
index 210efc12202a..0562140e7758 100644
--- a/dev-ruby/racc/ChangeLog
+++ b/dev-ruby/racc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/racc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.82 2012/11/06 16:54:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/ChangeLog,v 1.83 2012/12/01 15:47:29 graaff Exp $
+
+*racc-1.4.9 (01 Dec 2012)
+
+ 01 Dec 2012; Hans de Graaff <graaff@gentoo.org> +racc-1.4.9.ebuild:
+ Version bump. Drop ree18 since tests are broken and ree18 will be masked
+ shortly anyway.
06 Nov 2012; Jeroen Roovers <jer@gentoo.org> racc-1.4.6-r1.ebuild:
Stable for HPPA (bug #411507).
diff --git a/dev-ruby/racc/racc-1.4.9.ebuild b/dev-ruby/racc/racc-1.4.9.ebuild
new file mode 100644
index 000000000000..f2dcaadff66e
--- /dev/null
+++ b/dev-ruby/racc/racc-1.4.9.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.4.9.ebuild,v 1.1 2012/12/01 15:47:29 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc README.ja.rdoc TODO ChangeLog"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A LALR(1) parser generator for Ruby"
+HOMEPAGE="http://www.loveruby.net/en/racc.html"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "dev-ruby/rake
+ doc? ( dev-ruby/hoe )
+ test? ( dev-ruby/hoe )"
+
+all_ruby_prepare() {
+ sed -i -e 's|/tmp/out|${TMPDIR:-/tmp}/out|' test/helper.rb || die "tests fix failed"
+
+ # Avoid depending on rake-compiler since we don't use it to compile
+ # the extension.
+ sed -i -e '/rake-compiler/ s:^:#:' -e '/extensiontask/ s:^:#:' Rakefile
+ sed -i -e '/ExtensionTask/,/^ end/ s:^:#:' Rakefile
+
+ # Avoid isolation since dependencies are not properly declared.
+ sed -i -e 's/, :isolate//' Rakefile || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *ruby18)
+ sed -i -e '/test_norule_y/,/end/ s:^:#:' \
+ -e '/test_unterm_y/,/end/ s:^:#:' test/test_racc_command.rb || die
+ ${RUBY} -Cext/racc extconf.rb || die
+ ;;
+ *)
+ ${RUBY} -Cext/racc extconf.rb || die
+ ;;
+ esac
+}
+
+each_ruby_compile() {
+ case ${RUBY} in
+ *jruby)
+ einfo "Under JRuby, racc cannot use the shared object parser, so instead"
+ einfo "you have to rely on the pure Ruby implementation."
+ ;;
+ *)
+ emake -Cext/racc
+ # Copy over the file here so that we don't have to do
+ # special ruby install for JRuby and the other
+ # implementations.
+ cp -l ext/racc/cparse$(get_modname) lib/racc/cparse$(get_modname) || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ewarn "Using JRuby 1.5.2 the tests are currently badly broken,"
+ ewarn "so they are disabled until a new racc or a new JRuby is"
+ ewarn "released."
+ ;;
+ *)
+ each_fakegem_test
+ ;;
+ esac
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r rdoc
+
+ docinto examples
+ dodoc -r sample
+}