summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-30 08:06:46 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-30 08:06:46 +0000
commit969defe2090252538896dee7cc8b4ce758f76b14 (patch)
tree85d7c2db3e28192807bde8fb30db3f6aa071edc7 /dev-ruby/rack
parentVersion bump. Fix destruction of cbr archives when opened w/ p7zip, fix hang (diff)
downloadgentoo-2-969defe2090252538896dee7cc8b4ce758f76b14.tar.gz
gentoo-2-969defe2090252538896dee7cc8b4ce758f76b14.tar.bz2
gentoo-2-969defe2090252538896dee7cc8b4ce758f76b14.zip
Add revision bumps for security bug 396455.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rack')
-rw-r--r--dev-ruby/rack/ChangeLog13
-rw-r--r--dev-ruby/rack/rack-1.1.3-r1.ebuild42
-rw-r--r--dev-ruby/rack/rack-1.1.3.ebuild40
-rw-r--r--dev-ruby/rack/rack-1.2.5.ebuild74
-rw-r--r--dev-ruby/rack/rack-1.3.6.ebuild61
-rw-r--r--dev-ruby/rack/rack-1.4.0.ebuild61
6 files changed, 290 insertions, 1 deletions
diff --git a/dev-ruby/rack/ChangeLog b/dev-ruby/rack/ChangeLog
index 83de92530c56..7dbe663fbf6c 100644
--- a/dev-ruby/rack/ChangeLog
+++ b/dev-ruby/rack/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-ruby/rack
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.65 2011/12/29 06:52:38 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.66 2011/12/30 08:06:46 graaff Exp $
+
+*rack-1.4.0 (30 Dec 2011)
+*rack-1.3.6 (30 Dec 2011)
+*rack-1.2.5 (30 Dec 2011)
+*rack-1.1.3-r1 (30 Dec 2011)
+*rack-1.1.3 (30 Dec 2011)
+
+ 30 Dec 2011; Hans de Graaff <graaff@gentoo.org> +rack-1.1.3.ebuild,
+ +rack-1.1.3-r1.ebuild, +rack-1.2.5.ebuild, +rack-1.3.6.ebuild,
+ +rack-1.4.0.ebuild:
+ Add revision bumps for security bug 396455.
29 Dec 2011; Hans de Graaff <graaff@gentoo.org> rack-1.1.0-r1.ebuild,
rack-1.1.2.ebuild:
diff --git a/dev-ruby/rack/rack-1.1.3-r1.ebuild b/dev-ruby/rack/rack-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..0566be20291e
--- /dev/null
+++ b/dev-ruby/rack/rack-1.1.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.1.3-r1.ebuild,v 1.1 2011/12/30 08:06:46 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rubyforge.org/projects/rack"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all.
+ruby_add_bdepend "test? ( dev-ruby/test-spec )"
+
+all_ruby_prepare() {
+ # Avoid tests depending on now randomized hash ordering.
+ sed -i -e '/foobarfoo/ s:^:#:' test/spec_rack_response.rb || die
+ sed -i -e '/should build query strings correctly/,/end/ s:^:#:' test/spec_rack_utils.rb || die
+ sed -i -e '/should build nested query strings correctly/,/end/ s:^:#:' test/spec_rack_utils.rb || die
+}
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S specrb -Ilib:test -w -a \
+ -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|rackup)' \
+ || die "test failed for ${RUBY}"
+}
diff --git a/dev-ruby/rack/rack-1.1.3.ebuild b/dev-ruby/rack/rack-1.1.3.ebuild
new file mode 100644
index 000000000000..03cf1048787e
--- /dev/null
+++ b/dev-ruby/rack/rack-1.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.1.3.ebuild,v 1.1 2011/12/30 08:06:46 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rubyforge.org/projects/rack"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all.
+ruby_add_bdepend "test? ( dev-ruby/test-spec )"
+
+all_ruby_prepare() {
+ # Avoid tests depending on now randomized hash ordering.
+ sed -i -e '/foobarfoo/ s:^:#:' test/spec_rack_response.rb || die
+ sed -i -e '/should build query strings correctly/,/end/ s:^:#:' test/spec_rack_utils.rb || die
+ sed -i -e '/should build nested query strings correctly/,/end/ s:^:#:' test/spec_rack_utils.rb || die
+}
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S specrb -Ilib:test -w -a \
+ -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|rackup)' \
+ || die "test failed for ${RUBY}"
+}
diff --git a/dev-ruby/rack/rack-1.2.5.ebuild b/dev-ruby/rack/rack-1.2.5.ebuild
new file mode 100644
index 000000000000..e4c948c282b8
--- /dev/null
+++ b/dev-ruby/rack/rack-1.2.5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.2.5.ebuild,v 1.1 2011/12/30 08:06:46 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog KNOWN-ISSUES README SPEC"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rubyforge.org/projects/rack"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all. We do add the fcgi dependency because
+# that spec isn't optional.
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/ruby-fcgi )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.3-r1"
+
+#USE_RUBY=ruby19 \
+# ruby_add_bdepend "ruby_targets_ruby19 test" '=dev-ruby/test-unit-1*'
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.1-gentoo.patch
+
+ # Add missing require for Mutex use. This may show up in the tests
+ # depending on load order.
+ sed -i -e '1 irequire "thread"' lib/rack/lock.rb || die
+
+ # Avoid tests depending on now randomized hash ordering.
+ sed -i -e '/foobarfoo/ s:^:#:' test/spec_response.rb || die
+ sed -i -e '/should build query strings correctly/,/end/ s:^:#:' test/spec_utils.rb || die
+ sed -i -e '/should build nested query strings correctly/,/end/ s:^:#:' test/spec_utils.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19)
+ # Avoid failing encoding-related specs, most likely due to
+ # changes in handling of encodings in newer ruby 19
+ # versions.
+ sed -i -e '/escape non-UTF8 strings/,/end/ s:^:#:' test/spec_utils.rb || die
+ sed -i -e '/escape html entities in unicode strings/,/end/ s:^:#:' test/spec_utils.rb || die
+ sed -i -e '/escape html entities even on MRI/,/^ end/ s:^:#:' test/spec_utils.rb || die
+ sed -i -e '/accept params and build multipart encoded params/,/^ end/ s:^:#:' test/spec_mock.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|rackup)' \
+ || die "test failed for ${RUBY}"
+}
diff --git a/dev-ruby/rack/rack-1.3.6.ebuild b/dev-ruby/rack/rack-1.3.6.ebuild
new file mode 100644
index 000000000000..61123ab47b06
--- /dev/null
+++ b/dev-ruby/rack/rack-1.3.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.3.6.ebuild,v 1.1 2011/12/30 08:06:46 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog KNOWN-ISSUES README.rdoc SPEC"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rubyforge.org/projects/rack"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all. We do add the fcgi dependency because
+# that spec isn't optional.
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/ruby-fcgi )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.3-r1:0 !<dev-ruby/rack-1.2.5:1.2"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.1-gentoo.patch
+
+ # Avoid tests depending on now randomized hash ordering.
+ sed -i -e '/foobarfoo/ s:^:#:' test/spec_response.rb || die
+ sed -i -e '/build query strings correctly/,/end/ s:^:#:' test/spec_utils.rb || die
+ sed -i -e '/build nested query strings correctly/,/end/ s:^:#:' test/spec_utils.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Avoid two failing tests due to bugs in jruby that should
+ # be solved in 1.6.5 or 1.7.
+ rm test/spec_deflater.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
+ || die "test failed for ${RUBY}"
+}
diff --git a/dev-ruby/rack/rack-1.4.0.ebuild b/dev-ruby/rack/rack-1.4.0.ebuild
new file mode 100644
index 000000000000..48cbee1c10fc
--- /dev/null
+++ b/dev-ruby/rack/rack-1.4.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.4.0.ebuild,v 1.1 2011/12/30 08:06:46 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog KNOWN-ISSUES README.rdoc SPEC"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rubyforge.org/projects/rack"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all. We do add the fcgi dependency because
+# that spec isn't optional.
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/ruby-fcgi )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.3-r1:0 !<dev-ruby/rack-1.2.5:1.2 !<dev-ruby/rack-1.3.6:1.3"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.1-gentoo.patch
+
+ # Avoid tests depending on now randomized hash ordering.
+ sed -i -e '/foobarfoo/ s:^:#:' test/spec_response.rb || die
+ sed -i -e '/build query strings correctly/,/end/ s:^:#:' test/spec_utils.rb || die
+ sed -i -e '/build nested query strings correctly/,/end/ s:^:#:' test/spec_utils.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Avoid two failing tests due to bugs in jruby that should
+ # be solved in 1.6.5 or 1.7.
+ rm test/spec_deflater.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
+ || die "test failed for ${RUBY}"
+}