summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-01-13 09:47:48 +0000
committerHans de Graaff <graaff@gentoo.org>2013-01-13 09:47:48 +0000
commite7b195a00c113c2b86f1e850b833a27ad81f9a65 (patch)
tree216ee4e7eb2ef5d54a1fc88ef766375f10713273 /dev-ruby/rack
parentVersion bump for security bug 451620. (diff)
downloadgentoo-2-e7b195a00c113c2b86f1e850b833a27ad81f9a65.tar.gz
gentoo-2-e7b195a00c113c2b86f1e850b833a27ad81f9a65.tar.bz2
gentoo-2-e7b195a00c113c2b86f1e850b833a27ad81f9a65.zip
Version bump for security bug 451620. Avoid broken specs on jruby, since they are already broken on 1.1.3 now and this version is old and only kept for Rails 2.3.x
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rack')
-rw-r--r--dev-ruby/rack/ChangeLog9
-rw-r--r--dev-ruby/rack/rack-1.1.4.ebuild55
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-ruby/rack/ChangeLog b/dev-ruby/rack/ChangeLog
index ca242665d6a3..892a25bf6c8f 100644
--- a/dev-ruby/rack/ChangeLog
+++ b/dev-ruby/rack/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/rack
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.95 2013/01/13 09:31:39 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.96 2013/01/13 09:47:48 graaff Exp $
+
+*rack-1.1.4 (13 Jan 2013)
+
+ 13 Jan 2013; Hans de Graaff <graaff@gentoo.org> +rack-1.1.4.ebuild:
+ Version bump for security bug 451620. Avoid broken specs on jruby, since they
+ are already broken on 1.1.3 now and this version is old and only kept for
+ Rails 2.3.x
*rack-1.2.6 (13 Jan 2013)
diff --git a/dev-ruby/rack/rack-1.1.4.ebuild b/dev-ruby/rack/rack-1.1.4.ebuild
new file mode 100644
index 000000000000..81b08a36ef53
--- /dev/null
+++ b/dev-ruby/rack/rack-1.1.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.1.4.ebuild,v 1.1 2013/01/13 09:47:48 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rubyforge.org/projects/rack"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all.
+ruby_add_bdepend "test? ( dev-ruby/test-spec )"
+
+all_ruby_prepare() {
+ # Avoid tests depending on now randomized hash ordering.
+ sed -i -e '/foobarfoo/ s:^:#:' test/spec_rack_response.rb || die
+ sed -i -e '/should build query strings correctly/,/end/ s:^:#:' test/spec_rack_utils.rb || die
+ sed -i -e '/should build nested query strings correctly/,/end/ s:^:#:' test/spec_rack_utils.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Avoid broken specs. Already broken in 1.1.3 and not likely
+ # to be fixed anymore due to the age of this version.
+ rm test/spec_rack_mock.rb test/spec_rack_runtime.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S specrb -Ilib:test -w -a \
+ -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|rackup)' \
+ || die "test failed for ${RUBY}"
+}