summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-26 18:06:26 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-26 18:06:26 +0000
commit5e261fbbb54c8d13f1391d7c3204e17f6da3e6dc (patch)
tree2059650374134e3b57195f5b824e3285f6c85345 /dev-ruby/rails
parentDelete older ebuild. (diff)
downloadgentoo-2-5e261fbbb54c8d13f1391d7c3204e17f6da3e6dc.tar.gz
gentoo-2-5e261fbbb54c8d13f1391d7c3204e17f6da3e6dc.tar.bz2
gentoo-2-5e261fbbb54c8d13f1391d7c3204e17f6da3e6dc.zip
Version bump for Rails 3.0.7.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-3.0.7.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index ad4dba81b3f6..9c62f78aea98 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.186 2011/02/21 20:12:22 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.187 2011/04/26 18:06:26 graaff Exp $
+
+*rails-3.0.7 (26 Apr 2011)
+
+ 26 Apr 2011; Hans de Graaff <graaff@gentoo.org> +rails-3.0.7.ebuild:
+ Version bump for Rails 3.0.7.
*rails-2.3.11 (21 Feb 2011)
diff --git a/dev-ruby/rails/rails-3.0.7.ebuild b/dev-ruby/rails/rails-3.0.7.ebuild
new file mode 100644
index 000000000000..88dd88aa4964
--- /dev/null
+++ b/dev-ruby/rails/rails-3.0.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-3.0.7.ebuild,v 1.1 2011/04/26 18:06:26 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-rails-0.16"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ =dev-ruby/bundler-1.0*
+ ~dev-ruby/railties-${PV}"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}