summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-09-19 05:41:08 +0000
committerHans de Graaff <graaff@gentoo.org>2014-09-19 05:41:08 +0000
commit15328d0ce5fbde927937677153e19dadf0c4471e (patch)
tree15ee80ba2e4e8ffcdcfd684592e6b780c02dc230 /dev-ruby/rb-inotify
parentAdd revision with ruby21 to create stable candidate. (diff)
downloadgentoo-2-15328d0ce5fbde927937677153e19dadf0c4471e.tar.gz
gentoo-2-15328d0ce5fbde927937677153e19dadf0c4471e.tar.bz2
gentoo-2-15328d0ce5fbde927937677153e19dadf0c4471e.zip
Add new revision for ruby21 and create stable candidate.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rb-inotify')
-rw-r--r--dev-ruby/rb-inotify/ChangeLog8
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.9.5-r1.ebuild51
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild4
3 files changed, 60 insertions, 3 deletions
diff --git a/dev-ruby/rb-inotify/ChangeLog b/dev-ruby/rb-inotify/ChangeLog
index f766f15aefd1..4d64ff548f37 100644
--- a/dev-ruby/rb-inotify/ChangeLog
+++ b/dev-ruby/rb-inotify/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rb-inotify
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-inotify/ChangeLog,v 1.32 2014/08/05 16:00:30 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-inotify/ChangeLog,v 1.33 2014/09/19 05:41:08 graaff Exp $
+
+*rb-inotify-0.9.5-r1 (19 Sep 2014)
+
+ 19 Sep 2014; Hans de Graaff <graaff@gentoo.org> rb-inotify-0.9.5.ebuild,
+ +rb-inotify-0.9.5-r1.ebuild:
+ Add new revision for ruby21 and create stable candidate.
05 Aug 2014; Manuel Rüger <mrueg@gentoo.org> rb-inotify-0.9.0.ebuild,
rb-inotify-0.9.5.ebuild:
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.9.5-r1.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..d640f8b714df
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.9.5-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-inotify/rb-inotify-0.9.5-r1.ebuild,v 1.1 2014/09/19 05:41:08 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+RUBY_FAKEGEM_GEMSPEC="rb-inotify.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI"
+HOMEPAGE="https://github.com/nex3/rb-inotify"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x64-macos"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ffi"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on jeweler.
+ sed -i -e '/:build/ s:^:#:' -e '/module Jeweler/,/^end/ s:^:#:' -e '/class Jeweler/,/^end/ s:^:#:' Rakefile || die
+
+ # Remove mandatory markup processor from yard options, bug 436112.
+ sed -i -e '/maruku/d' .yardopts || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # jruby has a native implementation and should not list ffi
+ # in the gemspec.
+ sed -i -e '/ffi/d' rb-inotify.gemspec || die
+ ;;
+ *)
+ ;;
+ esac
+}
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild
index e0e38ae181ec..b79560ce22c3 100644
--- a/dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild
+++ b/dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild,v 1.2 2014/08/05 16:00:29 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild,v 1.3 2014/09/19 05:41:08 graaff Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 jruby"
+USE_RUBY="ruby19 ruby20 jruby"
RUBY_FAKEGEM_TASK_TEST=""