summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-26 15:09:05 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-26 15:09:05 +0000
commit1719fd91be347afa4534bcbf4391b897fc30d7cf (patch)
treeb72fb0fe077ef9cdae09e7daacad2d9e13574d08 /dev-ruby/rdiscount
parentnet-nds/jxplorer: fixed bug #391713 (diff)
downloadgentoo-2-1719fd91be347afa4534bcbf4391b897fc30d7cf.tar.gz
gentoo-2-1719fd91be347afa4534bcbf4391b897fc30d7cf.tar.bz2
gentoo-2-1719fd91be347afa4534bcbf4391b897fc30d7cf.zip
Fix compilation with rake 0.9. Add ruby19.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rdiscount')
-rw-r--r--dev-ruby/rdiscount/ChangeLog5
-rw-r--r--dev-ruby/rdiscount/rdiscount-1.6.8.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-ruby/rdiscount/ChangeLog b/dev-ruby/rdiscount/ChangeLog
index 0cce11dd0528..2f4f78df3c2e 100644
--- a/dev-ruby/rdiscount/ChangeLog
+++ b/dev-ruby/rdiscount/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/rdiscount
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdiscount/ChangeLog,v 1.7 2011/12/26 15:00:28 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdiscount/ChangeLog,v 1.8 2011/12/26 15:09:05 graaff Exp $
+
+ 26 Dec 2011; Hans de Graaff <graaff@gentoo.org> rdiscount-1.6.8.ebuild:
+ Fix compilation with rake 0.9. Add ruby19.
26 Dec 2011; Hans de Graaff <graaff@gentoo.org> -rdiscount-1.6.5.ebuild:
Remove old version.
diff --git a/dev-ruby/rdiscount/rdiscount-1.6.8.ebuild b/dev-ruby/rdiscount/rdiscount-1.6.8.ebuild
index ce26f6b165b9..645bcd7ddf1d 100644
--- a/dev-ruby/rdiscount/rdiscount-1.6.8.ebuild
+++ b/dev-ruby/rdiscount/rdiscount-1.6.8.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdiscount/rdiscount-1.6.8.ebuild,v 1.5 2011/12/04 23:28:34 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdiscount/rdiscount-1.6.8.ebuild,v 1.6 2011/12/26 15:09:05 graaff Exp $
EAPI=2
# Has a native extension without jruby support.
-USE_RUBY="ruby18 ree18"
+USE_RUBY="ruby18 ruby19 ree18"
RUBY_FAKEGEM_TASK_TEST="test:unit"
@@ -30,6 +30,9 @@ all_ruby_prepare() {
# Remove rule that will force a rebuild when running tests.
sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die
+
+ # Provide RUBY variable no longer provided by rake.
+ sed -i -e "1 iRUBY=${RUBY}" Rakefile || die
}
each_ruby_configure() {