summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-02-03 21:54:23 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-02-03 21:54:23 +0000
commit96c2a81ec546d30b5a060997e913b72bab824dde (patch)
tree19e702bad26b40b7d6a61b8a330e00e8157cee7d /dev-ruby/rdiscount
parentVersion bump. (diff)
downloadgentoo-2-96c2a81ec546d30b5a060997e913b72bab824dde.tar.gz
gentoo-2-96c2a81ec546d30b5a060997e913b72bab824dde.tar.bz2
gentoo-2-96c2a81ec546d30b5a060997e913b72bab824dde.zip
Version bump. Add ruby22.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/rdiscount')
-rw-r--r--dev-ruby/rdiscount/ChangeLog7
-rw-r--r--dev-ruby/rdiscount/rdiscount-2.1.8.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-ruby/rdiscount/ChangeLog b/dev-ruby/rdiscount/ChangeLog
index 73efc857edaf..1a0dd116889c 100644
--- a/dev-ruby/rdiscount/ChangeLog
+++ b/dev-ruby/rdiscount/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rdiscount
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdiscount/ChangeLog,v 1.43 2015/01/17 19:53:53 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdiscount/ChangeLog,v 1.44 2015/02/03 21:54:23 mrueg Exp $
+
+*rdiscount-2.1.8 (03 Feb 2015)
+
+ 03 Feb 2015; Manuel Rüger <mrueg@gentoo.org> +rdiscount-2.1.8.ebuild:
+ Version bump. Add ruby22.
17 Jan 2015; Manuel Rüger <mrueg@gentoo.org> -rdiscount-1.6.8-r1.ebuild:
Remove old.
diff --git a/dev-ruby/rdiscount/rdiscount-2.1.8.ebuild b/dev-ruby/rdiscount/rdiscount-2.1.8.ebuild
new file mode 100644
index 000000000000..30fe2191b952
--- /dev/null
+++ b/dev-ruby/rdiscount/rdiscount-2.1.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdiscount/rdiscount-2.1.8.ebuild,v 1.1 2015/02/03 21:54:23 mrueg Exp $
+
+EAPI=5
+
+# Has a native extension without jruby support.
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="test:unit"
+
+RUBY_FAKEGEM_TASK_DOC="doc man"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Implementation of John Gruber's Markdown"
+HOMEPAGE="http://github.com/rtomayko/rdiscount"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+all_ruby_prepare() {
+ # Hanna is broken for us and therefore we don't have it in portage.
+ sed -i -e 's/hanna/rdoc/' Rakefile || die
+
+ # Remove rule that will force a rebuild when running tests.
+ sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die
+
+ # Provide RUBY variable no longer provided by rake.
+ sed -i -e "1 iRUBY=${RUBY}" Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext || die
+ cp ext/*$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/rdiscount.1
+}