summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2015-05-04 03:47:31 +0000
committerRick Farina <zerochaos@gentoo.org>2015-05-04 03:47:31 +0000
commit03dbc41562dfdac065c2e13763938eb6327ec417 (patch)
treed016a08257c9bb12e0828229e42ef9677b05a4f9 /dev-ruby/rjb
parentStable for PPC64 (bug #548530). (diff)
downloadgentoo-2-03dbc41562dfdac065c2e13763938eb6327ec417.tar.gz
gentoo-2-03dbc41562dfdac065c2e13763938eb6327ec417.tar.bz2
gentoo-2-03dbc41562dfdac065c2e13763938eb6327ec417.zip
version bump, improved hardened hack^H^H^H^Hhandling
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'dev-ruby/rjb')
-rw-r--r--dev-ruby/rjb/ChangeLog8
-rw-r--r--dev-ruby/rjb/rjb-1.5.3.ebuild (renamed from dev-ruby/rjb/rjb-1.4.9.ebuild)17
2 files changed, 20 insertions, 5 deletions
diff --git a/dev-ruby/rjb/ChangeLog b/dev-ruby/rjb/ChangeLog
index 82404b9b7c9c..1dd4e593de52 100644
--- a/dev-ruby/rjb/ChangeLog
+++ b/dev-ruby/rjb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rjb
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rjb/ChangeLog,v 1.5 2015/03/16 20:30:41 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rjb/ChangeLog,v 1.6 2015/05/04 03:47:31 zerochaos Exp $
+
+*rjb-1.5.3 (04 May 2015)
+
+ 04 May 2015; Rick Farina <zerochaos@gentoo.org> +rjb-1.5.3.ebuild,
+ -rjb-1.4.9.ebuild:
+ version bump, improved hardened hack^H^H^H^Hhandling
16 Mar 2015; Hans de Graaff <graaff@gentoo.org> -rjb-1.4.8.ebuild:
Cleanup.
diff --git a/dev-ruby/rjb/rjb-1.4.9.ebuild b/dev-ruby/rjb/rjb-1.5.3.ebuild
index 1c1b8fb8d49a..461b6b37c6d4 100644
--- a/dev-ruby/rjb/rjb-1.4.9.ebuild
+++ b/dev-ruby/rjb/rjb-1.5.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rjb/rjb-1.4.9.ebuild,v 1.1 2014/04/25 05:36:25 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rjb/rjb-1.5.3.ebuild,v 1.1 2015/05/04 03:47:31 zerochaos Exp $
EAPI=5
@@ -42,7 +42,7 @@ all_ruby_prepare() {
each_ruby_prepare() {
#dev-lang/ruby might need the "hardened" flag to enforce the following:
if use hardened; then
- paxctl -v /usr/bin/ruby 2>/dev/null | grep MPROTECT | grep disabled || ewarn '!!! rjb may only work if ruby is MPROTECT disabled, but not really sure\n please disable it if required using paxctl -m /usr/bin/ruby'
+ paxctl -v /usr/bin/ruby 2>/dev/null | grep MPROTECT | grep disabled || ewarn '!!! rjb will only work if ruby is MPROTECT disabled\n please disable it if required using paxctl -m /usr/bin/ruby'
fi
# force compilation of class file for our JVM
rm -rf data
@@ -69,5 +69,14 @@ each_ruby_install() {
}
each_ruby_test() {
- ${RUBY} -C test -I../lib:.:../ext test.rb || die
+ if use hardened; then
+ paxctl -v ${RUBY} 2>/dev/null | grep MPROTECT | grep -q disabled
+ if [ $? = 0 ]; then
+ ${RUBY} -C test -I../lib:.:../ext test.rb || die
+ else
+ ewarn "${RUBY} has MPROTECT enabled, rjb will not work until it is disabled, skipping tests."
+ fi
+ else
+ ${RUBY} -C test -I../lib:.:../ext test.rb || die
+ fi
}