summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-12-22 15:42:14 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-12-22 15:42:14 +0000
commite2f93a708b520bc4a8fd9dcd26e810d6fe6fe2f8 (patch)
tree939a26babcd97fb4099e4f4c141e2007744e9599 /dev-ruby/rjb
parentStable for HPPA (bug #478252). (diff)
downloadgentoo-2-e2f93a708b520bc4a8fd9dcd26e810d6fe6fe2f8.tar.gz
gentoo-2-e2f93a708b520bc4a8fd9dcd26e810d6fe6fe2f8.tar.bz2
gentoo-2-e2f93a708b520bc4a8fd9dcd26e810d6fe6fe2f8.zip
Version bump. Running tests now, but many are broken.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/rjb')
-rw-r--r--dev-ruby/rjb/ChangeLog7
-rw-r--r--dev-ruby/rjb/rjb-1.4.8.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-ruby/rjb/ChangeLog b/dev-ruby/rjb/ChangeLog
index 4c4c48355b6e..fb1f5732e9ed 100644
--- a/dev-ruby/rjb/ChangeLog
+++ b/dev-ruby/rjb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rjb
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rjb/ChangeLog,v 1.1 2013/12/15 16:41:32 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rjb/ChangeLog,v 1.2 2013/12/22 15:42:14 mrueg Exp $
+
+*rjb-1.4.8 (22 Dec 2013)
+
+ 22 Dec 2013; Manuel Rüger <mrueg@gentoo.org> +rjb-1.4.8.ebuild:
+ Version bump. Running tests now, but many are broken.
*rjb-1.4.5 (15 Dec 2013)
diff --git a/dev-ruby/rjb/rjb-1.4.8.ebuild b/dev-ruby/rjb/rjb-1.4.8.ebuild
new file mode 100644
index 000000000000..16c97696a9a5
--- /dev/null
+++ b/dev-ruby/rjb/rjb-1.4.8.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rjb/rjb-1.4.8.ebuild,v 1.1 2013/12/22 15:42:14 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_EXTRADOC="readme.txt ChangeLog"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit java-pkg-2 ruby-ng ruby-fakegem
+
+DESCRIPTION="Rjb is a Ruby-Java software bridge"
+HOMEPAGE="http://rjb.rubyforge.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples hardened"
+
+DEPEND=">=virtual/jdk-1.5
+ hardened? ( sys-apps/paxctl )"
+RDEPEND="virtual/jre"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+each_ruby_prepare() {
+ #dev-lang/ruby might need the "hardened" flag to enforce the following:
+ if use hardened; then
+ paxctl -v /usr/bin/ruby 2>/dev/null | grep MPROTECT | grep disabled || ewarn '!!! rjb may only work if ruby is MPROTECT disabled, but not really sure\n please disable it if required using paxctl -m /usr/bin/ruby'
+ fi
+ # force compilation of class file for our JVM
+ rm -rf data
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -C ext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+
+ # currently no elegant way to do this (bug #352765)
+ ruby_fakegem_newins ext/rjbcore.so lib/rjbcore.so
+
+ ruby_fakegem_doins -r data
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:ext test/test.rb || die
+}