summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-07-10 09:53:46 +0000
committerHans de Graaff <graaff@gentoo.org>2014-07-10 09:53:46 +0000
commitdcff4ea69f4661831d5e061261317fbea62193af (patch)
treef0b2e1b5bdb011249509631647c5d3e06df0bb40 /dev-ruby/rspec
parentStable for amd64 wrt bug #507142 (diff)
downloadgentoo-2-dcff4ea69f4661831d5e061261317fbea62193af.tar.gz
gentoo-2-dcff4ea69f4661831d5e061261317fbea62193af.tar.bz2
gentoo-2-dcff4ea69f4661831d5e061261317fbea62193af.zip
Add ruby20, ruby21. Drop sparc keyword, bug 465948.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rspec')
-rw-r--r--dev-ruby/rspec/ChangeLog7
-rw-r--r--dev-ruby/rspec/rspec-1.3.2-r1.ebuild95
2 files changed, 101 insertions, 1 deletions
diff --git a/dev-ruby/rspec/ChangeLog b/dev-ruby/rspec/ChangeLog
index affabe0bad36..5457b2494726 100644
--- a/dev-ruby/rspec/ChangeLog
+++ b/dev-ruby/rspec/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rspec
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.166 2014/06/16 15:41:50 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/ChangeLog,v 1.167 2014/07/10 09:53:46 graaff Exp $
+
+*rspec-1.3.2-r1 (10 Jul 2014)
+
+ 10 Jul 2014; Hans de Graaff <graaff@gentoo.org> +rspec-1.3.2-r1.ebuild:
+ Add ruby20, ruby21. Drop sparc keyword, bug 465948.
16 Jun 2014; Tobias Klausmann <klausman@gentoo.org> rspec-2.14.1-r1.ebuild:
Keyworded on alpha, bug #465948
diff --git a/dev-ruby/rspec/rspec-1.3.2-r1.ebuild b/dev-ruby/rspec/rspec-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..0ad838f3207b
--- /dev/null
+++ b/dev-ruby/rspec/rspec-1.3.2-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec/rspec-1.3.2-r1.ebuild,v 1.1 2014/07/10 09:53:46 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc TODO.txt Ruby1.9.rdoc Upgrade.rdoc"
+
+RUBY_FAKEGEM_BINWRAP="spec"
+
+RUBY_FAKEGEM_GEMSPEC="rspec.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+# it's actually optional, but tests fail if it's not installed and
+# some other package might fail tests, so require it anyway.
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.2"
+
+RDEPEND="!<dev-ruby/rspec-rails-${PV}"
+
+# don't require test dependencies for jruby since we cannot run them
+# for now (fakefs doesn't work).
+#
+# We should add nokogiri here to make sure that we test as much as
+# possible, but since it's yet unported to 1.9 and the nokogiri-due
+# tests fail for sure, we'll be waiting on it.
+USE_RUBY="ruby19" \
+ ruby_add_bdepend "test? (
+ >=dev-ruby/hoe-2.0.0
+ dev-ruby/zentest
+ >=dev-ruby/syntax-1.0
+ >=dev-ruby/fakefs-0.2.1 )"
+USE_RUBY="ruby19" ruby_add_bdepend "test? ( =dev-ruby/test-unit-1.2.3 )"
+
+all_ruby_prepare() {
+ # Avoid dependency on git.
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Replace reference to /tmp to our temporary directory to avoid
+ # sandbox-related failure.
+ sed -i \
+ -e "s:/tmp:${T}:" \
+ spec/spec/runner/command_line_spec.rb || die
+
+ # Avoid unneeded dependency on bundler
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Avoid the formatter specs since they require output files for each
+ # ruby version and these are not present for any current ruby
+ # version.
+ rm spec/spec/runner/formatter/{html,text_mate}_formatter_spec.rb || die
+
+ # Drop heckle dependency.
+ rm spec/spec/runner/heckler_spec.rb spec/spec/runner/heckle_runner_spec.rb || die
+ sed -i -e '381,398 s:^:#:' spec/spec/runner/option_parser_spec.rb || die
+
+ # Avoid a spec that may fail on unimportant whitespace differences.
+ sed -e '/Diff in context format/,/^end/ s:^:#:' \
+ -i spec/spec/expectations/differs/default_spec.rb || die
+
+ # Remove broken spec.opts related tests. These were always broken
+ # because they don't set up state properly, but only with
+ # >=fakefs-0.4.2 this started throwing exceptions, bug 340385.
+ sed -i -e '/implicitly loading spec/,/^ end/ s:^:#:' spec/spec/runner/option_parser_spec.rb || die
+
+}
+
+src_test() {
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+ ruby-ng_src_test
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ewarn "Tests for JRuby are disabled because dev-ruby/fakefs does not currently support"
+ ewarn "JRuby properly and it's needed to run the tests."
+ ;;
+ *)
+ each_fakegem_test
+ ;;
+ esac
+}