summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-05-10 19:27:27 +0000
committerAlex Legler <a3li@gentoo.org>2009-05-10 19:27:27 +0000
commita30ee40e19db4b785f79fb278c0d84bf3f288736 (patch)
tree6b397b9bf355345d0e2554942c098a7a492be109 /dev-ruby/ruby-fcgi
parentNew version for GNOME 2.26. Small bug fixes. (diff)
downloadgentoo-2-a30ee40e19db4b785f79fb278c0d84bf3f288736.tar.gz
gentoo-2-a30ee40e19db4b785f79fb278c0d84bf3f288736.tar.bz2
gentoo-2-a30ee40e19db4b785f79fb278c0d84bf3f288736.zip
Version bump, bug 236064.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-fcgi')
-rw-r--r--dev-ruby/ruby-fcgi/ChangeLog10
-rw-r--r--dev-ruby/ruby-fcgi/files/ruby-fcgi-0.8.7-19compat.patch78
-rw-r--r--dev-ruby/ruby-fcgi/ruby-fcgi-0.8.7-r1.ebuild34
3 files changed, 120 insertions, 2 deletions
diff --git a/dev-ruby/ruby-fcgi/ChangeLog b/dev-ruby/ruby-fcgi/ChangeLog
index e28046ace5fc..d978acd582d4 100644
--- a/dev-ruby/ruby-fcgi/ChangeLog
+++ b/dev-ruby/ruby-fcgi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-fcgi
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-fcgi/ChangeLog,v 1.26 2008/12/05 09:48:32 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-fcgi/ChangeLog,v 1.27 2009/05/10 19:27:23 a3li Exp $
+
+*ruby-fcgi-0.8.7-r1 (10 May 2009)
+
+ 10 May 2009; Alex Legler <a3li@gentoo.org> +ruby-fcgi-0.8.7-r1.ebuild,
+ +files/ruby-fcgi-0.8.7-19compat.patch:
+ Version bump, bug 236064.
05 Dec 2008; Raúl Porcel <armin76@gentoo.org> ruby-fcgi-0.8.7.ebuild:
ia64/sparc stable wrt #249386
diff --git a/dev-ruby/ruby-fcgi/files/ruby-fcgi-0.8.7-19compat.patch b/dev-ruby/ruby-fcgi/files/ruby-fcgi-0.8.7-19compat.patch
new file mode 100644
index 000000000000..c444fa05742b
--- /dev/null
+++ b/dev-ruby/ruby-fcgi/files/ruby-fcgi-0.8.7-19compat.patch
@@ -0,0 +1,78 @@
+Patch for Ruby 1.9 compatibility, backport from upstream SVN.
+
+--- ext/fcgi/fcgi.c 2006-06-25 06:06:42.000000000 +0200
++++ ext/fcgi/fcgi.c.r47 2008-12-02 10:37:47.000000000 +0100
+@@ -17,6 +17,16 @@
+ #include "fcgiapp.h"
+ #endif
+
++#ifndef RARRAY_PTR
++#define RARRAY_LEN(ary) (RARRAY(ary)->len)
++#define RARRAY_PTR(ary) (RARRAY(ary)->ptr)
++#endif
++
++#ifndef RSTRING_PTR
++#define RSTRING_LEN(str) (RSTRING(str)->len)
++#define RSTRING_PTR(str) (RSTRING(str)->ptr)
++#endif
++
+ static VALUE cFCGI;
+ static VALUE eFCGIError;
+ static VALUE cFCGIStream;
+@@ -222,7 +232,7 @@
+ rb_secure(4);
+ Data_Get_Struct(self, FCGX_Stream, stream);
+ str = rb_obj_as_string(str);
+- len = FCGX_PutStr(RSTRING(str)->ptr, RSTRING(str)->len, stream);
++ len = FCGX_PutStr(RSTRING_PTR(str), RSTRING_LEN(str), stream);
+ if (len == EOF) CHECK_STREAM_ERROR(stream);
+ return INT2NUM(len);
+ }
+@@ -271,8 +281,8 @@
+ VALUE tmp;
+ int i;
+
+- for (i=0; i<RARRAY(ary)->len; i++) {
+- tmp = RARRAY(ary)->ptr[i];
++ for (i=0; i<RARRAY_LEN(ary); i++) {
++ tmp = RARRAY_PTR(ary)[i];
+ if (rb_inspecting_p(tmp)) {
+ tmp = rb_str_new2("[...]");
+ }
+@@ -305,7 +315,7 @@
+ }
+ line = rb_obj_as_string(line);
+ fcgi_stream_write(out, line);
+- if (RSTRING(line)->ptr[RSTRING(line)->len-1] != '\n') {
++ if (RSTRING_PTR(line)[RSTRING_LEN(line)-1] != '\n') {
+ fcgi_stream_write(out, rb_default_rs);
+ }
+ }
+@@ -379,7 +389,7 @@
+ rb_str_cat(str, buff, strlen(buff));
+ if (strchr(buff, '\n')) break;
+ }
+- if (RSTRING(str)->len > 0)
++ if (RSTRING_LEN(str) > 0)
+ return str;
+ else
+ return Qnil;
+@@ -507,7 +517,8 @@
+
+
+
+-void Init_fcgi() {
++void Init_fcgi()
++{
+
+ FCGX_Init();
+
+@@ -517,7 +528,7 @@
+ rb_define_singleton_method(cFCGI, "each", fcgi_s_each, 0);
+ rb_define_singleton_method(cFCGI, "each_request", fcgi_s_each, 0);
+ rb_define_singleton_method(cFCGI, "is_cgi?", fcgi_s_iscgi, 0);
+- rb_define_method(cFCGI, "in", fcgi_in, 0);
++ rb_define_method(cFCGI, "in", fcgi_in, 0);
+ rb_define_method(cFCGI, "out", fcgi_out, 0);
+ rb_define_method(cFCGI, "err", fcgi_err, 0);
+ rb_define_method(cFCGI, "env", fcgi_env, 0);
diff --git a/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.7-r1.ebuild b/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.7-r1.ebuild
new file mode 100644
index 000000000000..ac65cc128bd5
--- /dev/null
+++ b/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.7-r1.ebuild,v 1.1 2009/05/10 19:27:23 a3li Exp $
+
+inherit ruby
+
+DESCRIPTION="FastCGI library for Ruby"
+HOMEPAGE="http://rubyforge.org/projects/fcgi/"
+SRC_URI="mirror://rubyforge/fcgi/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+LICENSE="Ruby"
+
+DEPEND="dev-libs/fcgi"
+RDEPEND="${DEPEND}"
+
+IUSE=""
+
+USE_RUBY="ruby18 ruby19"
+PATCHES=( "${FILESDIR}/${P}-19compat.patch" )
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step.
+
+src_install() {
+ RUBY_ECONF="${RUBY_ECONF} ${EXTRA_ECONF}"
+
+ ${RUBY} install.rb install --prefix="${D}" "$@" \
+ ${RUBY_ECONF} || die "install.rb install failed"
+
+ cd "${S}"
+ dodoc ChangeLog README README.signals
+}