summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-22 20:13:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-22 20:13:34 +0000
commita6083304f6d7ff14a90bf764a6b7b129978aa1c5 (patch)
tree9704af17e47199a8a8a0996a20f5f3c4a64fe2b5 /dev-ruby/ruby-fcgi
parentDon't install .la files in site-packages directories. (diff)
downloadgentoo-2-a6083304f6d7ff14a90bf764a6b7b129978aa1c5.tar.gz
gentoo-2-a6083304f6d7ff14a90bf764a6b7b129978aa1c5.tar.bz2
gentoo-2-a6083304f6d7ff14a90bf764a6b7b129978aa1c5.zip
Remove old versions.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-fcgi')
-rw-r--r--dev-ruby/ruby-fcgi/ChangeLog6
-rw-r--r--dev-ruby/ruby-fcgi/ruby-fcgi-0.8.7-r2.ebuild46
-rw-r--r--dev-ruby/ruby-fcgi/ruby-fcgi-0.8.7-r3.ebuild40
3 files changed, 5 insertions, 87 deletions
diff --git a/dev-ruby/ruby-fcgi/ChangeLog b/dev-ruby/ruby-fcgi/ChangeLog
index ab6566ac6836..d7292658baf7 100644
--- a/dev-ruby/ruby-fcgi/ChangeLog
+++ b/dev-ruby/ruby-fcgi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ruby-fcgi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-fcgi/ChangeLog,v 1.35 2010/05/22 15:46:07 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-fcgi/ChangeLog,v 1.36 2010/05/22 20:13:34 flameeyes Exp $
+
+ 22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -ruby-fcgi-0.8.7-r2.ebuild, -ruby-fcgi-0.8.7-r3.ebuild:
+ Remove old versions.
22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
ruby-fcgi-0.8.7-r2.ebuild:
diff --git a/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.7-r2.ebuild b/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.7-r2.ebuild
deleted file mode 100644
index dab7ad762c7b..000000000000
--- a/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.7-r2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.7-r2.ebuild,v 1.3 2010/05/22 15:46:07 flameeyes Exp $
-
-inherit ruby
-
-DESCRIPTION="FastCGI library for Ruby"
-HOMEPAGE="http://rubyforge.org/projects/fcgi/"
-SRC_URI="mirror://rubyforge/fcgi/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-LICENSE="Ruby"
-
-DEPEND="dev-libs/fcgi"
-RDEPEND="${DEPEND}"
-
-IUSE=""
-
-USE_RUBY="ruby18"
-PATCHES=( "${FILESDIR}/${P}-19compat.patch" )
-
-# Use a custom src_install instead of the default one in ruby.eclass
-# because the one in ruby.eclass does not include setting the prefix
-# for the installation step.
-
-src_compile() {
- # If it's not 1.8 we have no business here at all!
- ${RUBY} --version | fgrep -q 'ruby 1.8' || \
- return 0
-
- ruby_src_compile
-}
-
-src_install() {
- if ${RUBY} --version | fgrep -q 'ruby 1.8'; then
- ${RUBY} install.rb install --prefix="${D}" \
- || die "install.rb install failed"
- else
- # Just install the fcgi.rb file, easier than trying to get to
- # reason with the install.rb script.
- doruby lib/fcgi.rb || die
- fi
-
- cd "${S}"
- dodoc ChangeLog README README.signals || die
-}
diff --git a/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.7-r3.ebuild b/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.7-r3.ebuild
deleted file mode 100644
index 6f9f61ae8e5a..000000000000
--- a/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.7-r3.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-fcgi/ruby-fcgi-0.8.7-r3.ebuild,v 1.2 2010/02/01 11:31:55 flameeyes Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_NAME="${PN/ruby-/}"
-
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="README README.signals ChangeLog"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="FastCGI library for Ruby"
-HOMEPAGE="http://rubyforge.org/projects/fcgi/"
-SRC_URI="mirror://rubyforge/fcgi/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-LICENSE="Ruby"
-
-DEPEND="dev-libs/fcgi"
-RDEPEND="${DEPEND}"
-
-IUSE=""
-SLOT="0"
-
-each_ruby_compile() {
- case ${RUBY} in
- *ruby18)
- pushd ext/fcgi
- ${RUBY} extconf.rb || die "extconf failed"
- emake || die "emake ext failed"
- popd
- cp ext/fcgi/fcgi.so lib || die
- ;;
- esac
-}