summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-16 17:49:39 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-16 17:49:39 +0000
commit28c527e40aa59cd42e6c30f6e0e816341d365e93 (patch)
treec16a06fe61ddbd337585eb9aba2dbc31c62b197b /dev-ruby/ruby-postgres
parentVersion bump. Clean up patches. (diff)
downloadgentoo-2-28c527e40aa59cd42e6c30f6e0e816341d365e93.tar.gz
gentoo-2-28c527e40aa59cd42e6c30f6e0e816341d365e93.tar.bz2
gentoo-2-28c527e40aa59cd42e6c30f6e0e816341d365e93.zip
Use proper name and version number to install the gem so that it matches the specification we now install. Fixes bug 354615.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-postgres')
-rw-r--r--dev-ruby/ruby-postgres/ChangeLog9
-rw-r--r--dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r2.ebuild48
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/ruby-postgres/ChangeLog b/dev-ruby/ruby-postgres/ChangeLog
index c0f53bd09a03..dd5247537672 100644
--- a/dev-ruby/ruby-postgres/ChangeLog
+++ b/dev-ruby/ruby-postgres/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/ruby-postgres
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ChangeLog,v 1.34 2011/01/15 11:23:11 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ChangeLog,v 1.35 2011/06/16 17:49:39 graaff Exp $
+
+*ruby-postgres-0.7.9.20080128-r2 (16 Jun 2011)
+
+ 16 Jun 2011; Hans de Graaff <graaff@gentoo.org>
+ +ruby-postgres-0.7.9.20080128-r2.ebuild:
+ Use proper name and version number to install the gem so that it matches the
+ specification we now install. Fixes bug 354615.
15 Jan 2011; Hans de Graaff <graaff@gentoo.org>
-ruby-postgres-0.7.1.ebuild:
diff --git a/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r2.ebuild b/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r2.ebuild
new file mode 100644
index 000000000000..a3a7752f2c98
--- /dev/null
+++ b/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-postgres/ruby-postgres-0.7.9.20080128-r2.ebuild,v 1.1 2011/06/16 17:49:39 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Contributors README"
+
+RUBY_FAKEGEM_NAME="postgres"
+
+# changes 0.7.1.20060406 to 0.7.1.2006.04.06
+
+# ideally, PV would have been this to start with, but can't change it now as
+# 0.7.1.20051221 > 0.7.1.2006.04.06.
+RUBY_FAKEGEM_VERSION="0.7.9.2008.01.28"
+
+inherit multilib ruby-fakegem versionator
+
+MY_P="${RUBY_FAKEGEM_NAME}-${RUBY_FAKEGEM_VERSION}"
+
+DESCRIPTION="An extension library to access a PostgreSQL database from Ruby"
+HOMEPAGE="http://ruby.scripting.ca/postgres"
+SRC_URI="mirror://rubygems/${MY_P}.gem"
+LICENSE="GPL-2 Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="${RDEPEND} dev-db/postgresql-base"
+DEPEND="${DEPEND} dev-db/postgresql-base"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext || die
+}
+
+each_ruby_install() {
+ mkdir lib || die
+ mv ext/postgres$(get_modname) lib/ || die
+
+ each_fakegem_install
+}