summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-01-20 07:16:21 +0000
committerHans de Graaff <graaff@gentoo.org>2014-01-20 07:16:21 +0000
commit8b466d2bd29582a9b7c5aa7ac0debe16400049c3 (patch)
tree386e67fc828f176884998f2980b09f5dab8c06f5 /dev-ruby/ruby-progressbar
parentsys-kernel/aufs-sources: Drop old (diff)
downloadgentoo-2-8b466d2bd29582a9b7c5aa7ac0debe16400049c3.tar.gz
gentoo-2-8b466d2bd29582a9b7c5aa7ac0debe16400049c3.tar.bz2
gentoo-2-8b466d2bd29582a9b7c5aa7ac0debe16400049c3.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/ruby-progressbar')
-rw-r--r--dev-ruby/ruby-progressbar/ChangeLog10
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.4.0.ebuild29
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-ruby/ruby-progressbar/ChangeLog b/dev-ruby/ruby-progressbar/ChangeLog
index 635f80662568..7c59fe782785 100644
--- a/dev-ruby/ruby-progressbar/ChangeLog
+++ b/dev-ruby/ruby-progressbar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-progressbar
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ChangeLog,v 1.53 2013/08/10 15:01:37 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ChangeLog,v 1.54 2014/01/20 07:16:21 graaff Exp $
+
+*ruby-progressbar-1.4.0 (20 Jan 2014)
+
+ 20 Jan 2014; Hans de Graaff <graaff@gentoo.org>
+ +ruby-progressbar-1.4.0.ebuild:
+ Version bump.
16 Feb 2013; Agostino Sarubbo <ago@gentoo.org> ruby-progressbar-1.0.2.ebuild:
Add ~x86, wrt bug #437582
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.4.0.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.4.0.ebuild
new file mode 100644
index 000000000000..69ab06b500f3
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ruby-progressbar-1.4.0.ebuild,v 1.1 2014/01/20 07:16:21 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' spec/spec_helper.rb || die
+}