summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-01-29 00:36:26 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-01-29 00:36:26 +0000
commitd809403c3e808dbc9c3f7420de4c3b8cbf135b41 (patch)
tree95a8a06bc7105f8bc3cafd10758d32a1b998992a /dev-ruby/ruby-progressbar
parentVersion bump. (diff)
downloadgentoo-2-d809403c3e808dbc9c3f7420de4c3b8cbf135b41.tar.gz
gentoo-2-d809403c3e808dbc9c3f7420de4c3b8cbf135b41.tar.bz2
gentoo-2-d809403c3e808dbc9c3f7420de4c3b8cbf135b41.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/ruby-progressbar')
-rw-r--r--dev-ruby/ruby-progressbar/ChangeLog7
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.4.1.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/ruby-progressbar/ChangeLog b/dev-ruby/ruby-progressbar/ChangeLog
index 7c59fe782785..922b5394eeb3 100644
--- a/dev-ruby/ruby-progressbar/ChangeLog
+++ b/dev-ruby/ruby-progressbar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ruby-progressbar
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ChangeLog,v 1.54 2014/01/20 07:16:21 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ChangeLog,v 1.55 2014/01/29 00:36:26 mrueg Exp $
+
+*ruby-progressbar-1.4.1 (29 Jan 2014)
+
+ 29 Jan 2014; Manuel Rüger <mrueg@gentoo.org> +ruby-progressbar-1.4.1.ebuild:
+ Version bump.
*ruby-progressbar-1.4.0 (20 Jan 2014)
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.4.1.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.4.1.ebuild
new file mode 100644
index 000000000000..7d2e06e4270d
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ruby-progressbar-1.4.1.ebuild,v 1.1 2014/01/29 00:36:26 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' spec/spec_helper.rb || die
+}