summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-22 01:59:11 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-22 01:59:11 +0000
commit13b90765986b1e447b6423fd5c620ac6c68a225a (patch)
tree3536635c44496c5af9e1340ab7ba826a874380db /dev-ruby/six/six-0.2.0.ebuild
parentAdd improvements from dev-zero's overlay. (diff)
downloadgentoo-2-13b90765986b1e447b6423fd5c620ac6c68a225a.tar.gz
gentoo-2-13b90765986b1e447b6423fd5c620ac6c68a225a.tar.bz2
gentoo-2-13b90765986b1e447b6423fd5c620ac6c68a225a.zip
Initial ebuild by Tiziano Müller (dev-zero).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/six/six-0.2.0.ebuild')
-rw-r--r--dev-ruby/six/six-0.2.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/six/six-0.2.0.ebuild b/dev-ruby/six/six-0.2.0.ebuild
new file mode 100644
index 000000000000..fc750eced103
--- /dev/null
+++ b/dev-ruby/six/six-0.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/six/six-0.2.0.ebuild,v 1.1 2013/11/22 01:59:11 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An ultra lite authorization library"
+HOMEPAGE="https://github.com/randx/six"
+SRC_URI="https://github.com/randx/six/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' spec/spec_helper.rb || die "sed failed"
+}