summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-05 22:35:55 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-07-05 22:35:55 +0000
commit315f9bdbfadb8ee42a4f7a58ba45295a1806707e (patch)
treede5ce1624bb9680675a2b3c54244bf31aed679c2 /dev-ruby/stomp
parentFix line info generation for gdb in clang, thanks Ben Longbons <b.r.longbons@... (diff)
downloadgentoo-2-315f9bdbfadb8ee42a4f7a58ba45295a1806707e.tar.gz
gentoo-2-315f9bdbfadb8ee42a4f7a58ba45295a1806707e.tar.bz2
gentoo-2-315f9bdbfadb8ee42a4f7a58ba45295a1806707e.zip
Version bump; use the new rspec support in 1.2.2 as well; remove 1.2.0.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/stomp')
-rw-r--r--dev-ruby/stomp/ChangeLog9
-rw-r--r--dev-ruby/stomp/stomp-1.2.2.ebuild7
-rw-r--r--dev-ruby/stomp/stomp-1.2.4.ebuild (renamed from dev-ruby/stomp/stomp-1.2.0.ebuild)11
3 files changed, 13 insertions, 14 deletions
diff --git a/dev-ruby/stomp/ChangeLog b/dev-ruby/stomp/ChangeLog
index 4b171335826d..6ac917bed2d2 100644
--- a/dev-ruby/stomp/ChangeLog
+++ b/dev-ruby/stomp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/stomp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/stomp/ChangeLog,v 1.10 2012/04/21 07:33:13 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/stomp/ChangeLog,v 1.11 2012/07/05 22:35:55 flameeyes Exp $
+
+*stomp-1.2.4 (05 Jul 2012)
+
+ 05 Jul 2012; Diego E. Pettenò <flameeyes@gentoo.org> +stomp-1.2.4.ebuild,
+ -stomp-1.2.0.ebuild, stomp-1.2.2.ebuild:
+ Version bump; use the new rspec support in 1.2.2 as well; remove 1.2.0.
*stomp-1.2.2 (21 Apr 2012)
@@ -44,4 +50,3 @@
28 Feb 2011; Hans de Graaff <graaff@gentoo.org> +stomp-1.1.7.ebuild,
+metadata.xml:
Initial import based on ebuild from ramereth in bug 351475.
-
diff --git a/dev-ruby/stomp/stomp-1.2.2.ebuild b/dev-ruby/stomp/stomp-1.2.2.ebuild
index 9880148c5cf3..f70515e91a01 100644
--- a/dev-ruby/stomp/stomp-1.2.2.ebuild
+++ b/dev-ruby/stomp/stomp-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/stomp/stomp-1.2.2.ebuild,v 1.1 2012/04/21 07:33:13 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/stomp/stomp-1.2.2.ebuild,v 1.2 2012/07/05 22:35:55 flameeyes Exp $
EAPI="2"
@@ -9,8 +9,7 @@ USE_RUBY="ruby18 ruby19 ree18"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
-# There is also a test task but that requires a live stomp server.
-RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
inherit ruby-fakegem
@@ -21,5 +20,3 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
diff --git a/dev-ruby/stomp/stomp-1.2.0.ebuild b/dev-ruby/stomp/stomp-1.2.4.ebuild
index 70d30d21bd6a..799b9825f8a5 100644
--- a/dev-ruby/stomp/stomp-1.2.0.ebuild
+++ b/dev-ruby/stomp/stomp-1.2.4.ebuild
@@ -1,16 +1,15 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/stomp/stomp-1.2.0.ebuild,v 1.1 2011/12/25 08:25:13 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/stomp/stomp-1.2.4.ebuild,v 1.1 2012/07/05 22:35:55 flameeyes Exp $
-EAPI="2"
+EAPI=4
USE_RUBY="ruby18 ruby19 ree18"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
-# There is also a test task but that requires a live stomp server.
-RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
inherit ruby-fakegem
@@ -21,5 +20,3 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"