summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-23 22:37:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-23 22:37:11 +0000
commit377464fcf946a206bddc5c87d7ef4cbd9e110df7 (patch)
tree5e36c698bef60a8471d6aacecd64e8799d81b537 /dev-ruby/storable
parentInitial import of the yajl bindings for Ruby, optionally used by the new vers... (diff)
downloadgentoo-2-377464fcf946a206bddc5c87d7ef4cbd9e110df7.tar.gz
gentoo-2-377464fcf946a206bddc5c87d7ef4cbd9e110df7.tar.bz2
gentoo-2-377464fcf946a206bddc5c87d7ef4cbd9e110df7.zip
Remove old version; update to new syntax; allow use of yajl-ruby in place of json.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/storable')
-rw-r--r--dev-ruby/storable/ChangeLog7
-rw-r--r--dev-ruby/storable/storable-0.7.3.ebuild43
-rw-r--r--dev-ruby/storable/storable-0.7.4.ebuild8
3 files changed, 12 insertions, 46 deletions
diff --git a/dev-ruby/storable/ChangeLog b/dev-ruby/storable/ChangeLog
index c1de65928527..e66ea7b1bfc1 100644
--- a/dev-ruby/storable/ChangeLog
+++ b/dev-ruby/storable/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/storable
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.11 2010/05/02 11:25:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/ChangeLog,v 1.12 2010/05/23 22:37:11 flameeyes Exp $
+
+ 23 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -storable-0.7.3.ebuild, storable-0.7.4.ebuild:
+ Remove old version; update to new syntax; allow use of yajl-ruby in place
+ of json.
*storable-0.7.4 (02 May 2010)
diff --git a/dev-ruby/storable/storable-0.7.3.ebuild b/dev-ruby/storable/storable-0.7.3.ebuild
deleted file mode 100644
index 5e8a9e39400b..000000000000
--- a/dev-ruby/storable/storable-0.7.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.7.3.ebuild,v 1.3 2010/05/01 00:51:31 flameeyes Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_TASK_DOC="rdoc"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Marshal Ruby classes into and out of multiple formats"
-HOMEPAGE="http://solutious.com/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-SRC_URI="http://github.com/delano/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
-S="${WORKDIR}/delano-${PN}-87e937b"
-
-ruby_add_bdepend test dev-ruby/tryouts
-
-all_ruby_prepare() {
- mv bin examples || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib -S sergeant || die "tests failed"
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/* || die
-}
diff --git a/dev-ruby/storable/storable-0.7.4.ebuild b/dev-ruby/storable/storable-0.7.4.ebuild
index f9109d111a0f..812cfc30f8c0 100644
--- a/dev-ruby/storable/storable-0.7.4.ebuild
+++ b/dev-ruby/storable/storable-0.7.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.7.4.ebuild,v 1.1 2010/05/02 11:25:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/storable/storable-0.7.4.ebuild,v 1.2 2010/05/23 22:37:11 flameeyes Exp $
EAPI=2
@@ -25,7 +25,11 @@ IUSE=""
SRC_URI="http://github.com/delano/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
S="${WORKDIR}/delano-${PN}-*"
-ruby_add_bdepend test dev-ruby/tryouts
+# technically, it could work without either; on the other hand, it
+# would break a bit of stuff.
+ruby_add_rdepend "|| ( dev-ruby/json dev-ruby/yajl-ruby )"
+
+ruby_add_bdepend "test? ( dev-ruby/tryouts )"
all_ruby_prepare() {
mv bin examples || die