summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-02-24 06:49:59 +0000
committerHans de Graaff <graaff@gentoo.org>2011-02-24 06:49:59 +0000
commit225f6fe80b821a160009293ab5cfa58d8e32c5df (patch)
tree401db6417fa2def92f3ea5f5d327ccc61e37e038 /dev-ruby/syntax/syntax-1.0.0-r3.ebuild
parentVersion bump to be in sync with the rest; no code changes. Remove old (diff)
downloadgentoo-2-225f6fe80b821a160009293ab5cfa58d8e32c5df.tar.gz
gentoo-2-225f6fe80b821a160009293ab5cfa58d8e32c5df.tar.bz2
gentoo-2-225f6fe80b821a160009293ab5cfa58d8e32c5df.zip
Juggle around with revisions to get a stable candidate.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/syntax/syntax-1.0.0-r3.ebuild')
-rw-r--r--dev-ruby/syntax/syntax-1.0.0-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/syntax/syntax-1.0.0-r3.ebuild b/dev-ruby/syntax/syntax-1.0.0-r3.ebuild
new file mode 100644
index 000000000000..d31d5adba950
--- /dev/null
+++ b/dev-ruby/syntax/syntax-1.0.0-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syntax/syntax-1.0.0-r3.ebuild,v 1.1 2011/02/24 06:49:59 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+# Seem to get stuck, somebody should look into it, most likely.
+RESTRICT=test
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Syntax highlighting for sourcecode and HTML"
+HOMEPAGE="http://syntax.rubyforge.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/ALL-TESTS.rb || die "tests failed"
+}