summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-09 01:24:05 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-09 01:24:05 +0000
commitd94d9610d6b489379c6d1f03e51da8666fda823a (patch)
treed86ffca904d876bf03be6ea19dfa4a71c2e8b8fb /dev-ruby/systemu/systemu-2.5.2-r1.ebuild
parentVersion bump wrt bug 485260 (diff)
downloadgentoo-2-d94d9610d6b489379c6d1f03e51da8666fda823a.tar.gz
gentoo-2-d94d9610d6b489379c6d1f03e51da8666fda823a.tar.bz2
gentoo-2-d94d9610d6b489379c6d1f03e51da8666fda823a.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/systemu/systemu-2.5.2-r1.ebuild')
-rw-r--r--dev-ruby/systemu/systemu-2.5.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/systemu/systemu-2.5.2-r1.ebuild b/dev-ruby/systemu/systemu-2.5.2-r1.ebuild
new file mode 100644
index 000000000000..b01a8d3f7bfb
--- /dev/null
+++ b/dev-ruby/systemu/systemu-2.5.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/systemu/systemu-2.5.2-r1.ebuild,v 1.1 2013/10/09 01:24:05 mrueg Exp $
+
+EAPI=5
+# Test hangs on jruby
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Universal capture of STDOUT and STDERR and handling of child process PID"
+HOMEPAGE="http://codeforpeople.com/lib/ruby/systemu/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+}