summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-09-12 08:54:45 +0000
committerHans de Graaff <graaff@gentoo.org>2010-09-12 08:54:45 +0000
commita442fc6247ae3fc70ced81ccafcc01bbef2894b7 (patch)
treeb05b2fdb270057a7a0117c27ad08c0b05418102f /dev-ruby/term-ansicolor
parentBug #160192: Trim old gnuconfig_update versions. (diff)
downloadgentoo-2-a442fc6247ae3fc70ced81ccafcc01bbef2894b7.tar.gz
gentoo-2-a442fc6247ae3fc70ced81ccafcc01bbef2894b7.tar.bz2
gentoo-2-a442fc6247ae3fc70ced81ccafcc01bbef2894b7.zip
Add ree18.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/term-ansicolor')
-rw-r--r--dev-ruby/term-ansicolor/ChangeLog8
-rw-r--r--dev-ruby/term-ansicolor/term-ansicolor-1.0.5-r1.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/term-ansicolor/ChangeLog b/dev-ruby/term-ansicolor/ChangeLog
index 001575246fa8..0ced26aed776 100644
--- a/dev-ruby/term-ansicolor/ChangeLog
+++ b/dev-ruby/term-ansicolor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/term-ansicolor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/term-ansicolor/ChangeLog,v 1.8 2010/08/11 05:33:17 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/term-ansicolor/ChangeLog,v 1.9 2010/09/12 08:54:45 graaff Exp $
+
+*term-ansicolor-1.0.5-r1 (12 Sep 2010)
+
+ 12 Sep 2010; Hans de Graaff <graaff@gentoo.org>
+ +term-ansicolor-1.0.5-r1.ebuild:
+ Add ree18.
11 Aug 2010; Hans de Graaff <graaff@gentoo.org>
-term-ansicolor-1.0.4.ebuild, -term-ansicolor-1.0.4-r1.ebuild:
diff --git a/dev-ruby/term-ansicolor/term-ansicolor-1.0.5-r1.ebuild b/dev-ruby/term-ansicolor/term-ansicolor-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..d93ae1518516
--- /dev/null
+++ b/dev-ruby/term-ansicolor/term-ansicolor-1.0.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/term-ansicolor/term-ansicolor-1.0.5-r1.ebuild,v 1.1 2010/09/12 08:54:45 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST="tests"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+# don't install a cdiff wrapper, collides with app-misc/colordiff (bug
+# #310073).
+RUBY_FAKEGEM_BINWRAP="decolor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Small Ruby library that colors strings using ANSI escape sequences."
+HOMEPAGE="http://term-ansicolor.rubyforge.org/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="examples"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ use examples && docinto examples && dodoc examples/*
+}