summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-06 13:56:42 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-06 13:56:42 +0000
commit89c9a61db5daa52073a322a11d3a23cd4c2b8846 (patch)
tree66557bcafc0c0985278c2b4a214e9827a46e8f4e /dev-ruby/test-unit
parentVersion bump. (diff)
downloadgentoo-2-89c9a61db5daa52073a322a11d3a23cd4c2b8846.tar.gz
gentoo-2-89c9a61db5daa52073a322a11d3a23cd4c2b8846.tar.bz2
gentoo-2-89c9a61db5daa52073a322a11d3a23cd4c2b8846.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog8
-rw-r--r--dev-ruby/test-unit/test-unit-2.1.1.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 7655c0408f26..698c7fb13a68 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.23 2010/07/30 17:32:33 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.24 2010/08/06 13:56:42 flameeyes Exp $
+
+*test-unit-2.1.1 (06 Aug 2010)
+
+ 06 Aug 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +test-unit-2.1.1.ebuild:
+ Version bump.
*test-unit-2.1.0-r1 (30 Jul 2010)
diff --git a/dev-ruby/test-unit/test-unit-2.1.1.ebuild b/dev-ruby/test-unit/test-unit-2.1.1.ebuild
new file mode 100644
index 000000000000..e8f8665b087b
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-2.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.1.1.ebuild,v 1.1 2010/08/06 13:56:42 flameeyes Exp $
+
+EAPI=2
+# One test fails on jruby, might be a jruby bug
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="TODO README.txt History.txt"
+
+# Disable default binwraps
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+ruby_add_bdepend "doc? ( dev-ruby/hoe )"
+
+DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
+HOMEPAGE="http://test-unit.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE=""
+
+each_ruby_test() {
+ # the rake audit using dev-ruby/zentest currently fails, and we
+ # just need to call the testsuite directly.
+ # rake audit || die "rake audit failed"
+ local rubyflags
+
+ [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
+
+ ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # Create a testrb2 wrapper similarly to the rdoc2 wrapper for
+ # rdoc-2* series.
+ ruby_fakegem_binwrapper testrb /usr/bin/testrb-2
+}