summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-09-23 15:56:40 +0000
committerHans de Graaff <graaff@gentoo.org>2012-09-23 15:56:40 +0000
commitc140e946bfb92ed29942522e1a4bde04f20e1ecd (patch)
tree78065b76018ac5f1ac6d3dd29741ffda90b3615c /dev-ruby/test-unit
parentCleanup. (diff)
downloadgentoo-2-c140e946bfb92ed29942522e1a4bde04f20e1ecd.tar.gz
gentoo-2-c140e946bfb92ed29942522e1a4bde04f20e1ecd.tar.bz2
gentoo-2-c140e946bfb92ed29942522e1a4bde04f20e1ecd.zip
Version bump.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog7
-rw-r--r--dev-ruby/test-unit/test-unit-2.5.2.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 576956ee8f8b..1166cd9d13e5 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.63 2012/09/23 15:54:57 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.64 2012/09/23 15:56:40 graaff Exp $
+
+*test-unit-2.5.2 (23 Sep 2012)
+
+ 23 Sep 2012; Hans de Graaff <graaff@gentoo.org> +test-unit-2.5.2.ebuild:
+ Version bump.
23 Sep 2012; Hans de Graaff <graaff@gentoo.org> -test-unit-2.1.2.ebuild:
Cleanup.
diff --git a/dev-ruby/test-unit/test-unit-2.5.2.ebuild b/dev-ruby/test-unit/test-unit-2.5.2.ebuild
new file mode 100644
index 000000000000..a98c96b85da9
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-2.5.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.5.2.ebuild,v 1.1 2012/09/23 15:56:40 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
+
+inherit ruby-fakegem
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+# redcloth is also needed to build documentation, but not available for
+# jruby. Since we build documentation with the main ruby implementation
+# only we skip the dependency for jruby in this roundabout way, assuming
+# that jruby won't be the main ruby.
+USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "doc? ( dev-ruby/redcloth )"
+
+DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
+HOMEPAGE="http://test-unit.rubyforge.org/"
+
+LICENSE="Ruby"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ yard doc --title ${PN} || die
+ fi
+}
+
+each_ruby_test() {
+ # the rake audit using dev-ruby/zentest currently fails, and we
+ # just need to call the testsuite directly.
+ # rake audit || die "rake audit failed"
+ local rubyflags
+
+ [[ ${RUBY} == */jruby ]] && rubyflags="-X+O"
+
+ ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbin "${FILESDIR}"/testrb testrb-2
+}