summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-08-20 19:37:47 +0000
committerHans de Graaff <graaff@gentoo.org>2014-08-20 19:37:47 +0000
commit1df9570f47aa14bd6b1ad27705ec876ebe29c089 (patch)
treec0cc0d2474153019de5cb3b893acdd4e7884b3f8 /dev-ruby/tilt
parentCleanup old. (diff)
downloadgentoo-2-1df9570f47aa14bd6b1ad27705ec876ebe29c089.tar.gz
gentoo-2-1df9570f47aa14bd6b1ad27705ec876ebe29c089.tar.bz2
gentoo-2-1df9570f47aa14bd6b1ad27705ec876ebe29c089.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/tilt')
-rw-r--r--dev-ruby/tilt/ChangeLog7
-rw-r--r--dev-ruby/tilt/tilt-2.0.1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-ruby/tilt/ChangeLog b/dev-ruby/tilt/ChangeLog
index 92a1ed01ebb9..a8c0aa19a29c 100644
--- a/dev-ruby/tilt/ChangeLog
+++ b/dev-ruby/tilt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/tilt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tilt/ChangeLog,v 1.34 2014/08/12 19:54:41 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tilt/ChangeLog,v 1.35 2014/08/20 19:37:47 graaff Exp $
+
+*tilt-2.0.1 (20 Aug 2014)
+
+ 20 Aug 2014; Hans de Graaff <graaff@gentoo.org> +tilt-2.0.1.ebuild:
+ Version bump.
12 Aug 2014; Anthony G. Basile <blueness@gentoo.org> tilt-1.4.1-r1.ebuild,
tilt-1.4.1.ebuild:
diff --git a/dev-ruby/tilt/tilt-2.0.1.ebuild b/dev-ruby/tilt/tilt-2.0.1.ebuild
new file mode 100644
index 000000000000..8ce1c03e4719
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tilt/tilt-2.0.1.ebuild,v 1.1 2014/08/20 19:37:47 graaff Exp $
+
+EAPI=5
+
+# jruby fails tests
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thin interface over a Ruby template engines to make their usage as generic as possible"
+HOMEPAGE="http://github.com/rtomayko/tilt"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to faciliate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/bluecloth
+ dev-ruby/coffee-script
+ dev-ruby/erubis
+ dev-ruby/nokogiri
+ dev-ruby/radius
+ !!<dev-ruby/maruku-0.7.2 )"
+
+# Most dependencies are optional: skip haml for ruby20 and ruby21
+# because haml depends on rails.
+USE_RUBY="ruby19" ruby_add_bdepend "test? ( dev-ruby/haml )"
+
+ruby_add_rdepend ">=dev-ruby/builder-2.0.0"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ sed -e '/test_smarty_pants_true/,/^ end/ s:^:#:' -i test/tilt_markdown_test.rb || die
+ sed -e '/smartypants when :smart is set/,/^ end/ s:^:#:' -i test/tilt_rdiscounttemplate_test.rb || die
+}