summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-04-19 03:13:34 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-04-19 03:13:34 +0000
commit20c936d310a170d1262df58e528d16c71f6333f7 (patch)
tree7fe1764af85a50d9b5a70b918037ca8f8a143596 /dev-ruby/tins
parentRemove ruby18 target. Cleanup old. (diff)
downloadgentoo-2-20c936d310a170d1262df58e528d16c71f6333f7.tar.gz
gentoo-2-20c936d310a170d1262df58e528d16c71f6333f7.tar.bz2
gentoo-2-20c936d310a170d1262df58e528d16c71f6333f7.zip
Remove ruby18 target.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/tins')
-rw-r--r--dev-ruby/tins/ChangeLog8
-rw-r--r--dev-ruby/tins/tins-0.13.1.ebuild4
-rw-r--r--dev-ruby/tins/tins-0.13.2.ebuild4
-rw-r--r--dev-ruby/tins/tins-1.1.0.ebuild29
4 files changed, 40 insertions, 5 deletions
diff --git a/dev-ruby/tins/ChangeLog b/dev-ruby/tins/ChangeLog
index 59410dc772f7..dd5e577b712a 100644
--- a/dev-ruby/tins/ChangeLog
+++ b/dev-ruby/tins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/tins
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/ChangeLog,v 1.37 2014/04/13 16:14:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/ChangeLog,v 1.38 2014/04/19 03:13:34 mrueg Exp $
+
+*tins-1.1.0 (19 Apr 2014)
+
+ 19 Apr 2014; Manuel Rüger <mrueg@gentoo.org> +tins-1.1.0.ebuild,
+ tins-0.13.1.ebuild, tins-0.13.2.ebuild:
+ Remove ruby18 target.
13 Apr 2014; Agostino Sarubbo <ago@gentoo.org> tins-0.13.1.ebuild:
Stable for ppc, wrt bug #490178
diff --git a/dev-ruby/tins/tins-0.13.1.ebuild b/dev-ruby/tins/tins-0.13.1.ebuild
index 89f03fec0c65..16bd351ec16d 100644
--- a/dev-ruby/tins/tins-0.13.1.ebuild
+++ b/dev-ruby/tins/tins-0.13.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/tins-0.13.1.ebuild,v 1.6 2014/04/13 16:14:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/tins-0.13.1.ebuild,v 1.7 2014/04/19 03:13:34 mrueg Exp $
EAPI=5
-USE_RUBY="ruby18 ruby19 ruby20 jruby"
+USE_RUBY="ruby19 ruby20 jruby"
RUBY_FAKEGEM_RECIPE_TEST="none"
diff --git a/dev-ruby/tins/tins-0.13.2.ebuild b/dev-ruby/tins/tins-0.13.2.ebuild
index a9f86a7ae974..a06d5a0ad076 100644
--- a/dev-ruby/tins/tins-0.13.2.ebuild
+++ b/dev-ruby/tins/tins-0.13.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/tins-0.13.2.ebuild,v 1.1 2014/02/05 00:03:59 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/tins-0.13.2.ebuild,v 1.2 2014/04/19 03:13:34 mrueg Exp $
EAPI=5
-USE_RUBY="ruby18 ruby19 ruby20 ruby21 jruby"
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
RUBY_FAKEGEM_RECIPE_TEST="none"
diff --git a/dev-ruby/tins/tins-1.1.0.ebuild b/dev-ruby/tins/tins-1.1.0.ebuild
new file mode 100644
index 000000000000..1adc1f4e49a0
--- /dev/null
+++ b/dev-ruby/tins/tins-1.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/tins/tins-1.1.0.ebuild,v 1.1 2014/04/19 03:13:34 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="All the stuff that isn't good enough for a real library."
+HOMEPAGE="http://github.com/flori/tins"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib tests/*_test.rb
+}