summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-04-23 05:52:32 +0000
committerHans de Graaff <graaff@gentoo.org>2013-04-23 05:52:32 +0000
commitf3317af9e72c3459b030ba82e11dc8e1df8c3510 (patch)
tree481a60755f09e8894092195c44e45d1ed31b11fa /dev-ruby/vlad
parentHomepage change, #460204 (diff)
downloadgentoo-2-f3317af9e72c3459b030ba82e11dc8e1df8c3510.tar.gz
gentoo-2-f3317af9e72c3459b030ba82e11dc8e1df8c3510.tar.bz2
gentoo-2-f3317af9e72c3459b030ba82e11dc8e1df8c3510.zip
Version bump.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/vlad')
-rw-r--r--dev-ruby/vlad/ChangeLog9
-rw-r--r--dev-ruby/vlad/vlad-2.4.1.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-ruby/vlad/ChangeLog b/dev-ruby/vlad/ChangeLog
index f11d13636a38..400d425e9759 100644
--- a/dev-ruby/vlad/ChangeLog
+++ b/dev-ruby/vlad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/vlad
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/ChangeLog,v 1.20 2012/12/11 07:25:03 graaff Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/ChangeLog,v 1.21 2013/04/23 05:52:32 graaff Exp $
+
+*vlad-2.4.1 (23 Apr 2013)
+
+ 23 Apr 2013; Hans de Graaff <graaff@gentoo.org> +vlad-2.4.1.ebuild:
+ Version bump.
*vlad-2.3.1 (11 Dec 2012)
diff --git a/dev-ruby/vlad/vlad-2.4.1.ebuild b/dev-ruby/vlad/vlad-2.4.1.ebuild
new file mode 100644
index 000000000000..5f8df80b3e26
--- /dev/null
+++ b/dev-ruby/vlad/vlad-2.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/vlad/vlad-2.4.1.ebuild,v 1.1 2013/04/23 05:52:32 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="considerations.txt History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pragmatic application deployment automation, without mercy."
+HOMEPAGE="http://rubyhitsquad.com/Vlad_the_Deployer.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend ">=dev-ruby/hoe-2.9.2 test? ( dev-ruby/minitest )"
+ruby_add_rdepend ">=dev-ruby/rake-remote_task-2.1"
+
+all_ruby_prepare() {
+ # Keep Isolate from managing the dependencies.
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}