summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-02 13:34:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-02 13:34:39 +0000
commit07b26c0e40f0e6685fd89ed18946b769c96c2806 (patch)
tree65ff63ccd3b7eecef07ed422199ffbc654167bea /dev-ruby
parentAdd patch to fix tests with Ruby 1.9.2 and add ruby19 compatibility. (diff)
downloadgentoo-2-07b26c0e40f0e6685fd89ed18946b769c96c2806.tar.gz
gentoo-2-07b26c0e40f0e6685fd89ed18946b769c96c2806.tar.bz2
gentoo-2-07b26c0e40f0e6685fd89ed18946b769c96c2806.zip
Add missing racc dependency; skip tests for JRuby since they require libraries we don't have (weakling).
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/nokogiri/ChangeLog6
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.4.4.ebuild12
2 files changed, 16 insertions, 2 deletions
diff --git a/dev-ruby/nokogiri/ChangeLog b/dev-ruby/nokogiri/ChangeLog
index 3648d35beea4..a83f06756f73 100644
--- a/dev-ruby/nokogiri/ChangeLog
+++ b/dev-ruby/nokogiri/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/nokogiri
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.47 2011/01/10 18:21:03 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.48 2011/02/02 13:34:39 flameeyes Exp $
+
+ 02 Feb 2011; Diego E. Pettenò <flameeyes@gentoo.org> nokogiri-1.4.4.ebuild:
+ Add missing racc dependency; skip tests for JRuby since they require
+ libraries we don't have (weakling).
10 Jan 2011; Hans de Graaff <graaff@gentoo.org> nokogiri-1.4.4.ebuild:
Keyword ~x86-macos.
diff --git a/dev-ruby/nokogiri/nokogiri-1.4.4.ebuild b/dev-ruby/nokogiri/nokogiri-1.4.4.ebuild
index 7cc4c3d038b4..6af9faf9647e 100644
--- a/dev-ruby/nokogiri/nokogiri-1.4.4.ebuild
+++ b/dev-ruby/nokogiri/nokogiri-1.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.4.4.ebuild,v 1.4 2011/01/10 18:21:03 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.4.4.ebuild,v 1.5 2011/02/02 13:34:39 flameeyes Exp $
EAPI=2
@@ -34,6 +34,7 @@ ruby_add_bdepend "
dev-ruby/rake-compiler
dev-ruby/rexical
dev-ruby/hoe
+ dev-ruby/racc
test? ( dev-ruby/minitest )"
ruby_add_rdepend "ffi? ( virtual/ruby-ffi )"
@@ -71,5 +72,14 @@ each_ruby_compile() {
each_ruby_test() {
nokogiri_ffi && export NOKOGIRI_FFI=yes
+
+ case ${RUBY} in
+ *jruby)
+ einfo "We don't have all the required libraries to test Nokogiri with JRuby."
+ einfo "the tests will be skipped for this implementation."
+ return
+ ;;
+ esac
+
each_fakegem_test
}