summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-12-14 16:58:23 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-12-14 16:58:23 +0000
commit25b432de3886da20789284e79ba31d5f32173eb1 (patch)
tree93ed1f26785c44018ca9e0ba73dd722cc05f89d7 /dev-ruby
parentBuilds also with ncurses[tinfo] (bug #458128) (diff)
downloadgentoo-2-25b432de3886da20789284e79ba31d5f32173eb1.tar.gz
gentoo-2-25b432de3886da20789284e79ba31d5f32173eb1.tar.bz2
gentoo-2-25b432de3886da20789284e79ba31d5f32173eb1.zip
Create a stable candidate of hoe-3.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/hoe/ChangeLog8
-rw-r--r--dev-ruby/hoe/hoe-3.13.0-r1.ebuild44
-rw-r--r--dev-ruby/hoe/hoe-3.13.0.ebuild4
3 files changed, 53 insertions, 3 deletions
diff --git a/dev-ruby/hoe/ChangeLog b/dev-ruby/hoe/ChangeLog
index 49886fceeae5..c455bd38345b 100644
--- a/dev-ruby/hoe/ChangeLog
+++ b/dev-ruby/hoe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/hoe
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.165 2014/10/29 18:48:28 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.166 2014/12/14 16:58:23 mrueg Exp $
+
+*hoe-3.13.0-r1 (14 Dec 2014)
+
+ 14 Dec 2014; Manuel Rüger <mrueg@gentoo.org> +hoe-3.13.0-r1.ebuild,
+ hoe-3.13.0.ebuild:
+ Create a stable candidate of hoe-3.
29 Oct 2014; Manuel Rüger <mrueg@gentoo.org> -files/hoe-2.10.0-test-fix.patch,
-files/hoe-2.5.0-tests.patch,
diff --git a/dev-ruby/hoe/hoe-3.13.0-r1.ebuild b/dev-ruby/hoe/hoe-3.13.0-r1.ebuild
new file mode 100644
index 000000000000..5b6888586a10
--- /dev/null
+++ b/dev-ruby/hoe/hoe-3.13.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-3.13.0-r1.ebuild,v 1.1 2014/12/14 16:58:23 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc Manifest.txt README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation"
+HOMEPAGE="http://seattlerb.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.3:5 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7 >=dev-ruby/rdoc-4.0"
+
+all_ruby_prepare() {
+ # Skip isolation
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+
+ # Skip test depending on specifics of gem command name
+ sed -i -e '/test_nosudo/,/^ end/ s:^:#:' test/test_hoe.rb || die
+
+ # Gem.bin_wrapper does not work as expected on Gentoo.
+ sed -i -e 's/Gem.bin_wrapper//' lib/hoe/rcov.rb lib/hoe/publish.rb test/test_hoe_publish.rb || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ rdoc --title "seattlerb's hoe-3.5.1 Documentation" -o doc --main README.txt lib History.txt Manifest.txt README.txt || die
+}
diff --git a/dev-ruby/hoe/hoe-3.13.0.ebuild b/dev-ruby/hoe/hoe-3.13.0.ebuild
index 708884713d40..5d8ea9e5b1e7 100644
--- a/dev-ruby/hoe/hoe-3.13.0.ebuild
+++ b/dev-ruby/hoe/hoe-3.13.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-3.13.0.ebuild,v 1.2 2014/10/29 18:48:28 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-3.13.0.ebuild,v 1.3 2014/12/14 16:58:23 mrueg Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_TASK_DOC=""