summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-11-27 06:58:57 +0000
committerHans de Graaff <graaff@gentoo.org>2008-11-27 06:58:57 +0000
commit47f36f04d7a4d52db3ef75d7b2af67fcac5894c9 (patch)
tree0145fef4b0acbb483f01ae302011f4fef5734ff6 /dev-ruby
parentVersion bump for Rails 2.2.2 (diff)
downloadgentoo-2-47f36f04d7a4d52db3ef75d7b2af67fcac5894c9.tar.gz
gentoo-2-47f36f04d7a4d52db3ef75d7b2af67fcac5894c9.tar.bz2
gentoo-2-47f36f04d7a4d52db3ef75d7b2af67fcac5894c9.zip
Version bump for Rails 2.2.2
(Portage version: 2.1.4.5)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activerecord/ChangeLog8
-rw-r--r--dev-ruby/activerecord/activerecord-2.2.2.ebuild21
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index c2841d510373..48c05d8db0a1 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.90 2008/11/17 06:23:44 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.91 2008/11/27 06:58:57 graaff Exp $
+
+*activerecord-2.2.2 (27 Nov 2008)
+
+ 27 Nov 2008; Hans de Graaff <graaff@gentoo.org>
+ +activerecord-2.2.2.ebuild:
+ Version bump for Rails 2.2.2
17 Nov 2008; Hans de Graaff <graaff@gentoo.org>
-activerecord-2.0.2.ebuild, -activerecord-2.0.4.ebuild,
diff --git a/dev-ruby/activerecord/activerecord-2.2.2.ebuild b/dev-ruby/activerecord/activerecord-2.2.2.ebuild
new file mode 100644
index 000000000000..9bd613bb681b
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.2.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.2.2.ebuild,v 1.1 2008/11/27 06:58:57 graaff Exp $
+
+inherit ruby gems
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mysql postgres sqlite sqlite3"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/ruby-1.8.5
+ ~dev-ruby/activesupport-2.2.2
+ sqlite? ( >=dev-ruby/sqlite-ruby-2.2.2 )
+ sqlite3? ( dev-ruby/sqlite3-ruby )
+ mysql? ( >=dev-ruby/mysql-ruby-2.7 )
+ postgres? ( >=dev-ruby/ruby-postgres-0.7.1 )"