summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-07-06 05:42:39 +0000
committerHans de Graaff <graaff@gentoo.org>2010-07-06 05:42:39 +0000
commit4a445013f23cf1e93c637b4f0670b14af65051df (patch)
tree4eb17a59b5f0ebc0610c23e1eb6be770654c6f17 /dev-ruby
parentSearch /usr/sbin for mount/fsck helpers. (diff)
downloadgentoo-2-4a445013f23cf1e93c637b4f0670b14af65051df.tar.gz
gentoo-2-4a445013f23cf1e93c637b4f0670b14af65051df.tar.bz2
gentoo-2-4a445013f23cf1e93c637b4f0670b14af65051df.zip
Version bump with bug fixes.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-activeldap/ChangeLog8
-rw-r--r--dev-ruby/ruby-activeldap/ruby-activeldap-1.2.2.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-ruby/ruby-activeldap/ChangeLog b/dev-ruby/ruby-activeldap/ChangeLog
index 6ddd0f350823..65ba99ae4803 100644
--- a/dev-ruby/ruby-activeldap/ChangeLog
+++ b/dev-ruby/ruby-activeldap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-activeldap
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-activeldap/ChangeLog,v 1.22 2010/05/23 19:57:47 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-activeldap/ChangeLog,v 1.23 2010/07/06 05:42:39 graaff Exp $
+
+*ruby-activeldap-1.2.2 (06 Jul 2010)
+
+ 06 Jul 2010; Hans de Graaff <graaff@gentoo.org>
+ +ruby-activeldap-1.2.2.ebuild:
+ Version bump with bug fixes.
*ruby-activeldap-1.2.1-r2 (23 May 2010)
diff --git a/dev-ruby/ruby-activeldap/ruby-activeldap-1.2.2.ebuild b/dev-ruby/ruby-activeldap/ruby-activeldap-1.2.2.ebuild
new file mode 100644
index 000000000000..a44ee5db37ef
--- /dev/null
+++ b/dev-ruby/ruby-activeldap/ruby-activeldap-1.2.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-activeldap/ruby-activeldap-1.2.2.ebuild,v 1.1 2010/07/06 05:42:39 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README TODO"
+RUBY_FAKEGEM_EXTRAINSTALL="data po rails rails_generators"
+RUBY_FAKEGEM_NAME="activeldap"
+
+inherit ruby-fakegem
+
+MY_P="${P/ruby-/}"
+DESCRIPTION="Ruby/ActiveLDAP provides an activerecord inspired object oriented interface to LDAP"
+HOMEPAGE="http://ruby-activeldap.rubyforge.org/doc/"
+SRC_URI="mirror://rubygems/${MY_P}.gem"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+# Most tests require a live LDAP server to run.
+RESTRICT="test"
+
+ruby_add_bdepend "dev-ruby/hoe"
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+ruby_add_rdepend "
+ =dev-ruby/activerecord-2.3*
+ ~dev-ruby/locale-2.0.5
+ ~dev-ruby/ruby-gettext-2.1.0
+ ~dev-ruby/gettext_activerecord-2.1.0
+ >=dev-ruby/ruby-ldap-0.8.2"
+
+all_ruby_prepare() {
+ # Make activeldap more lenient towards newer Rails versions.
+ sed -i -e "s/= 2.3.8/~>2.3.5/" lib/active_ldap.rb || die
+}
+
+each_ruby_test() {
+ # Tests use test-unit-2 which is currently masked in tree.
+ # Version 2.0.6 is bundled so use that for now.
+ RUBYLIB=test-unit/lib ${RUBY} -S rake test || die "Tests failed."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}