summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-09-13 18:01:51 +0000
committerHans de Graaff <graaff@gentoo.org>2010-09-13 18:01:51 +0000
commit52a0ef6b115ddc9ae7318b0ea4f09e4454ae5967 (patch)
tree36e03fed919656c7e39f3676493ffbbdb2343931 /dev-ruby
parentInitial import of rspec-2. (diff)
downloadgentoo-2-52a0ef6b115ddc9ae7318b0ea4f09e4454ae5967.tar.gz
gentoo-2-52a0ef6b115ddc9ae7318b0ea4f09e4454ae5967.tar.bz2
gentoo-2-52a0ef6b115ddc9ae7318b0ea4f09e4454ae5967.zip
Initial import of rspec-2.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-expectations/ChangeLog10
-rw-r--r--dev-ruby/rspec-expectations/metadata.xml5
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-2.0.0_beta22.ebuild49
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/rspec-expectations/ChangeLog b/dev-ruby/rspec-expectations/ChangeLog
new file mode 100644
index 000000000000..ce8edc045e85
--- /dev/null
+++ b/dev-ruby/rspec-expectations/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/rspec-expectations
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/ChangeLog,v 1.1 2010/09/13 18:01:51 graaff Exp $
+
+*rspec-expectations-2.0.0_beta22 (13 Sep 2010)
+
+ 13 Sep 2010; Hans de Graaff <graaff@gentoo.org>
+ +rspec-expectations-2.0.0_beta22.ebuild, +metadata.xml:
+ Initial import of rspec-2.
+
diff --git a/dev-ruby/rspec-expectations/metadata.xml b/dev-ruby/rspec-expectations/metadata.xml
new file mode 100644
index 000000000000..0040b1162894
--- /dev/null
+++ b/dev-ruby/rspec-expectations/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-2.0.0_beta22.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-2.0.0_beta22.ebuild
new file mode 100644
index 000000000000..4906e01ad7bf
--- /dev/null
+++ b/dev-ruby/rspec-expectations/rspec-expectations-2.0.0_beta22.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-expectations/rspec-expectations-2.0.0_beta22.ebuild,v 1.1 2010/09/13 18:01:51 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.markdown Upgrade.markdown"
+
+RUBY_FAKEGEM_VERSION="2.0.0.beta.22"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="mirror://rubygems/${PN}-${RUBY_FAKEGEM_VERSION}.gem"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/diff-lcs-1.1.2"
+
+ruby_add_bdepend "test? (
+ ~dev-ruby/rspec-core-${PV}
+ ~dev-ruby/rspec-mocks-${PV}
+ )"
+
+# Not clear yet to what extend we need those (now)
+# >=dev-ruby/cucumber-0.6.2
+# >=dev-ruby/aruba-0.1.1"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e "s|require 'bundler'|require 'rspec/expectations/version'|" Rakefile || die
+ sed -i -e '/Bundler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rake spec
+
+ # There are features but they require aruba which we don't have yet.
+}