summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-11-25 11:34:25 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-11-25 11:34:25 +0000
commit61d9f698406ce5fc030ef1b48add7e781e54786c (patch)
treea307373831ee8364f7f7a83e83c837efd711dfa3 /dev-ruby
parentSupport python 3.4 (diff)
downloadgentoo-2-61d9f698406ce5fc030ef1b48add7e781e54786c.tar.gz
gentoo-2-61d9f698406ce5fc030ef1b48add7e781e54786c.tar.bz2
gentoo-2-61d9f698406ce5fc030ef1b48add7e781e54786c.zip
Drop jruby target.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/thor/ChangeLog6
-rw-r--r--dev-ruby/thor/thor-0.15.2.ebuild4
-rw-r--r--dev-ruby/thor/thor-0.18.1.ebuild16
-rw-r--r--dev-ruby/thor/thor-0.19.1.ebuild16
4 files changed, 11 insertions, 31 deletions
diff --git a/dev-ruby/thor/ChangeLog b/dev-ruby/thor/ChangeLog
index 562e9c396605..c478e2b5beb1 100644
--- a/dev-ruby/thor/ChangeLog
+++ b/dev-ruby/thor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/thor
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/ChangeLog,v 1.22 2014/08/12 21:30:54 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/ChangeLog,v 1.23 2014/11/25 11:34:25 mrueg Exp $
+
+ 25 Nov 2014; Manuel Rüger <mrueg@gentoo.org> thor-0.15.2.ebuild,
+ thor-0.18.1.ebuild, thor-0.19.1.ebuild:
+ Drop jruby target.
12 Aug 2014; Anthony G. Basile <blueness@gentoo.org> thor-0.15.2.ebuild,
thor-0.18.1.ebuild, thor-0.19.1.ebuild:
diff --git a/dev-ruby/thor/thor-0.15.2.ebuild b/dev-ruby/thor/thor-0.15.2.ebuild
index cef2274a03ac..45d365690e9f 100644
--- a/dev-ruby/thor/thor-0.15.2.ebuild
+++ b/dev-ruby/thor/thor-0.15.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.15.2.ebuild,v 1.4 2014/08/12 21:30:54 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.15.2.ebuild,v 1.5 2014/11/25 11:34:25 mrueg Exp $
EAPI=4
-USE_RUBY="ruby19 jruby"
+USE_RUBY="ruby19"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_TASK_TEST=""
diff --git a/dev-ruby/thor/thor-0.18.1.ebuild b/dev-ruby/thor/thor-0.18.1.ebuild
index 1a0e1ca23997..279ab3c27950 100644
--- a/dev-ruby/thor/thor-0.18.1.ebuild
+++ b/dev-ruby/thor/thor-0.18.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.18.1.ebuild,v 1.5 2014/08/12 21:30:54 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.18.1.ebuild,v 1.6 2014/11/25 11:34:25 mrueg Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 jruby"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
@@ -46,15 +46,3 @@ all_ruby_prepare() {
# bug 430402
sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
}
-
-each_ruby_prepare() {
- # Skip two failing specs on thor. Our jruby 1.6 is too old to file
- # bugs against and the next thor version will no longer work with
- # this version altogether.
- case ${RUBY} in
- *jruby)
- sed -i -e '/works with glob characters in the path/,/end/ s:^:#:' \
- spec/actions/directory_spec.rb || die
- ;;
- esac
-}
diff --git a/dev-ruby/thor/thor-0.19.1.ebuild b/dev-ruby/thor/thor-0.19.1.ebuild
index c9be87fed665..ceb7af596016 100644
--- a/dev-ruby/thor/thor-0.19.1.ebuild
+++ b/dev-ruby/thor/thor-0.19.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.19.1.ebuild,v 1.2 2014/08/12 21:30:54 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/thor/thor-0.19.1.ebuild,v 1.3 2014/11/25 11:34:25 mrueg Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 jruby"
+USE_RUBY="ruby19 ruby20 ruby21"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
@@ -46,15 +46,3 @@ all_ruby_prepare() {
# bug 430402
sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
}
-
-each_ruby_prepare() {
- # Skip two failing specs on thor. Our jruby 1.6 is too old to file
- # bugs against and the next thor version will no longer work with
- # this version altogether.
- case ${RUBY} in
- *jruby)
- sed -i -e '/works with glob characters in the path/,/end/ s:^:#:' \
- spec/actions/directory_spec.rb || die
- ;;
- esac
-}