summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-03-22 07:03:43 +0000
committerHans de Graaff <graaff@gentoo.org>2014-03-22 07:03:43 +0000
commit834d459ba18ab9b2d6219f0aa1c354c3d5f35f75 (patch)
tree2c0783f93d9ea2dfe770a151e02f2409f916792c /dev-ruby
parentrevbump; add optional dep for testsuite, update ebuild according re python im... (diff)
downloadgentoo-2-834d459ba18ab9b2d6219f0aa1c354c3d5f35f75.tar.gz
gentoo-2-834d459ba18ab9b2d6219f0aa1c354c3d5f35f75.tar.bz2
gentoo-2-834d459ba18ab9b2d6219f0aa1c354c3d5f35f75.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/atomic/ChangeLog9
-rw-r--r--dev-ruby/atomic/atomic-1.1.16.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-ruby/atomic/ChangeLog b/dev-ruby/atomic/ChangeLog
index f635ed0e55e3..26d3aa49acb0 100644
--- a/dev-ruby/atomic/ChangeLog
+++ b/dev-ruby/atomic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/atomic
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/atomic/ChangeLog,v 1.12 2013/12/27 02:24:09 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/atomic/ChangeLog,v 1.13 2014/03/22 07:03:43 graaff Exp $
+
+*atomic-1.1.16 (22 Mar 2014)
+
+ 22 Mar 2014; Hans de Graaff <graaff@gentoo.org> +atomic-1.1.16.ebuild:
+ Version bump.
*atomic-1.1.14-r1 (27 Dec 2013)
diff --git a/dev-ruby/atomic/atomic-1.1.16.ebuild b/dev-ruby/atomic/atomic-1.1.16.ebuild
new file mode 100644
index 000000000000..88f021d0885d
--- /dev/null
+++ b/dev-ruby/atomic/atomic-1.1.16.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/atomic/atomic-1.1.16.ebuild,v 1.1 2014/03/22 07:03:43 graaff Exp $
+
+EAPI=5
+# jruby → there is code for this in ext but that requires compiling java.
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An atomic reference implementation for JRuby, Rubinius, and MRI"
+HOMEPAGE="https://github.com/headius/ruby-atomic"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid compilation dependencies since we compile directly.
+ sed -i -e '/:test => :compile/ s:^:#:' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/atomic_reference$(get_modname) lib/ || die
+}