summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-01-28 21:36:58 +0000
committerHans de Graaff <graaff@gentoo.org>2013-01-28 21:36:58 +0000
commit86f5e761765d850ca68bb254a9674663fccd807f (patch)
tree5958e649637bced0c7b38b79eb37b4874dfc5702 /dev-ruby
parentfix selinux for beta2, fix location of udev-init-scripts dep (diff)
downloadgentoo-2-86f5e761765d850ca68bb254a9674663fccd807f.tar.gz
gentoo-2-86f5e761765d850ca68bb254a9674663fccd807f.tar.bz2
gentoo-2-86f5e761765d850ca68bb254a9674663fccd807f.zip
Version bump for security bug 453844.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activesupport/ChangeLog8
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.16.ebuild45
-rw-r--r--dev-ruby/activesupport/files/activesupport-2.3.16-unvendorize.patch94
3 files changed, 146 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 545348db0cad..27a27891b745 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.204 2013/01/20 15:05:26 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.205 2013/01/28 21:36:58 graaff Exp $
+
+*activesupport-2.3.16 (28 Jan 2013)
+
+ 28 Jan 2013; Hans de Graaff <graaff@gentoo.org> +activesupport-2.3.16.ebuild,
+ +files/activesupport-2.3.16-unvendorize.patch:
+ Version bump for security bug 453844.
20 Jan 2013; Hans de Graaff <graaff@gentoo.org>
-activesupport-2.3.14-r1.ebuild, -activesupport-3.0.18.ebuild,
diff --git a/dev-ruby/activesupport/activesupport-2.3.16.ebuild b/dev-ruby/activesupport/activesupport-2.3.16.ebuild
new file mode 100644
index 000000000000..f194f7534ded
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.3.16.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.16.ebuild,v 1.1 2013/01/28 21:36:58 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/builder-2.1.2:0 >=dev-ruby/tzinfo-0.3.16 >=dev-ruby/i18n-0.4.1:0.4"
+
+all_ruby_prepare() {
+ # Remove the bundled packages!
+ rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
+ || die "failed to remove vendor packages"
+
+ # This patch removes the fallback to local vendorized gems, as well
+ # as fixing the dependencies for i18n to use the correct slot. It
+ # also edits the metadata file so that the dependencies are added to
+ # the specification, which is required for bundler to pick them up
+ # (which in turn is required by radiant 1.0.0rc3 to
+ # work). Furthermore remove the references to the vendorized copies
+ # from the specification, to be safe.
+ mv ../metadata . || die
+ epatch "${FILESDIR}"/${PN}-2.3.16-unvendorize.patch
+ mv metadata .. || die
+ sed -i -e '/\/vendor\//d' ../metadata
+
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-2.3.5-mocha-0.9.5.patch
+}
diff --git a/dev-ruby/activesupport/files/activesupport-2.3.16-unvendorize.patch b/dev-ruby/activesupport/files/activesupport-2.3.16-unvendorize.patch
new file mode 100644
index 000000000000..08994bd11645
--- /dev/null
+++ b/dev-ruby/activesupport/files/activesupport-2.3.16-unvendorize.patch
@@ -0,0 +1,94 @@
+Index: activesupport-2.3.5/lib/active_support/vendor.rb
+===================================================================
+--- activesupport-2.3.5.orig/lib/active_support/vendor.rb
++++ activesupport-2.3.5/lib/active_support/vendor.rb
+@@ -1,11 +1,7 @@
+ # Prefer gems to the bundled libs.
+ require 'rubygems'
+
+-begin
+- gem 'builder', '~> 2.1.2'
+-rescue Gem::LoadError
+- $:.unshift "#{File.dirname(__FILE__)}/vendor/builder-2.1.2"
+-end
++gem 'builder', '~> 2.1.2'
+ require 'builder'
+
+ begin
+@@ -14,15 +10,7 @@ rescue Gem::LoadError
+ $:.unshift "#{File.dirname(__FILE__)}/vendor/memcache-client-1.7.4"
+ end
+
+-begin
+- gem 'tzinfo', '~> 0.3.12'
+-rescue Gem::LoadError
+- $:.unshift "#{File.dirname(__FILE__)}/vendor/tzinfo-0.3.12"
+-end
++gem 'tzinfo', '~> 0.3.12'
+
+-begin
+- gem 'i18n', '>= 0.4.1'
+-rescue Gem::LoadError
+- $:.unshift "#{File.dirname(__FILE__)}/vendor/i18n-0.4.1"
+-end
++gem 'i18n', '~> 0.4.1'
+ require 'i18n'
+Index: metadata
+===================================================================
+--- a/metadata
++++ b/metadata
+@@ -16,5 +16,53 @@ bindir: bin
+ cert_chain: []
+ date: 2013-01-28 00:00:00.000000000 Z
+-dependencies: []
++dependencies:
++- !ruby/object:Gem::Dependency
++ name: builder
++ prerelease: false
++ requirement: &id001 !ruby/object:Gem::Requirement
++ none: false
++ requirements:
++ - - "~>"
++ - !ruby/object:Gem::Version
++ hash: 57
++ segments:
++ - 2
++ - 1
++ - 2
++ version: 2.1.2
++ type: :runtime
++ version_requirements: *id003
++- !ruby/object:Gem::Dependency
++ name: tzinfo
++ prerelease: false
++ requirement: &id002 !ruby/object:Gem::Requirement
++ none: false
++ requirements:
++ - - ">="
++ - !ruby/object:Gem::Version
++ hash: 57
++ segments:
++ - 0
++ - 3
++ - 16
++ version: 0.3.16
++ type: :runtime
++ version_requirements: *id003
++- !ruby/object:Gem::Dependency
++ name: i18n
++ prerelease: false
++ requirement: &id003 !ruby/object:Gem::Requirement
++ none: false
++ requirements:
++ - - "~>"
++ - !ruby/object:Gem::Version
++ hash: 57
++ segments:
++ - 0
++ - 4
++ - 1
++ version: 0.4.1
++ type: :runtime
++ version_requirements: *id003
+ description: Utility library which carries commonly used classes and goodies from the Rails framework
+ email: david@loudthinking.com