summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-04-07 13:10:26 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-04-07 13:10:26 +0000
commit8cf102ef796a33dcfa6f8dc75b6858897b9bcf5c (patch)
tree0e9fed55e60a85357232964d1540ea7ea75bcd8c /dev-ruby
parentAdd ~ia64 keyword wrt bug #505156 (diff)
downloadgentoo-2-8cf102ef796a33dcfa6f8dc75b6858897b9bcf5c.tar.gz
gentoo-2-8cf102ef796a33dcfa6f8dc75b6858897b9bcf5c.tar.bz2
gentoo-2-8cf102ef796a33dcfa6f8dc75b6858897b9bcf5c.zip
Initial version. Original ebuild by Tiziano Müller (dev-zero).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/pygments_rb/ChangeLog9
-rw-r--r--dev-ruby/pygments_rb/metadata.xml5
-rw-r--r--dev-ruby/pygments_rb/pygments_rb-0.5.4.ebuild59
3 files changed, 73 insertions, 0 deletions
diff --git a/dev-ruby/pygments_rb/ChangeLog b/dev-ruby/pygments_rb/ChangeLog
new file mode 100644
index 000000000000..dbbdd1b79628
--- /dev/null
+++ b/dev-ruby/pygments_rb/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-ruby/pygments_rb
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pygments_rb/ChangeLog,v 1.1 2014/04/07 13:10:26 mrueg Exp $
+
+*pygments_rb-0.5.4 (07 Apr 2014)
+
+ 07 Apr 2014; Manuel Rüger <mrueg@gentoo.org> +metadata.xml,
+ +pygments_rb-0.5.4.ebuild:
+ Initial version. Original ebuild by Tiziano Müller (dev-zero).
diff --git a/dev-ruby/pygments_rb/metadata.xml b/dev-ruby/pygments_rb/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/pygments_rb/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/pygments_rb/pygments_rb-0.5.4.ebuild b/dev-ruby/pygments_rb/pygments_rb-0.5.4.ebuild
new file mode 100644
index 000000000000..e09756a296f8
--- /dev/null
+++ b/dev-ruby/pygments_rb/pygments_rb-0.5.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pygments_rb/pygments_rb-0.5.4.ebuild,v 1.1 2014/04/07 13:10:26 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+RUBY_FAKEGEM_NAME="pygments.rb"
+MY_P="${RUBY_FAKEGEM_NAME}-${PV}"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem python-single-r1
+
+DESCRIPTION="pygments syntax highlighting in ruby"
+HOMEPAGE="https://github.com/tmm1/pygments.rb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE+=" ${PYTHON_REQUIRED_USE}"
+
+RUBY_S="${MY_P}"
+
+RDEPEND+=" dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND+=" test? ( ${RDEPEND} )"
+
+ruby_add_rdepend ">=dev-ruby/yajl-ruby-1.1
+ dev-ruby/posix-spawn"
+ruby_add_bdepend "dev-ruby/rake-compiler"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile || die "sed failed"
+ python_fix_shebang lib/pygments/mentos.py
+ # we are loosing a "custom github lexer here", no idea what it is,
+ # but if we need it, it should go into dev-python/pygments
+ rm -r vendor lexers || die "removing bundled libs failed"
+}
+
+each_ruby_compile() {
+ # regenerate the lexer cache, based on the system pygments pkg
+ ${RUBY} cache-lexers.rb || die "regenerating lexer cache failed"
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ ruby_fakegem_doins lexers
+}