summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-01-16 07:27:37 +0000
committerHans de Graaff <graaff@gentoo.org>2014-01-16 07:27:37 +0000
commit8d4dbd3cebfc7850e046cec1475c74f4e791463b (patch)
treed2db3243cab98c23690ff349201943d570c657e1 /dev-ruby
parentMark m68k/s390/sh stable. (diff)
downloadgentoo-2-8d4dbd3cebfc7850e046cec1475c74f4e791463b.tar.gz
gentoo-2-8d4dbd3cebfc7850e046cec1475c74f4e791463b.tar.bz2
gentoo-2-8d4dbd3cebfc7850e046cec1475c74f4e791463b.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rack-protection/ChangeLog10
-rw-r--r--dev-ruby/rack-protection/rack-protection-1.5.2.ebuild24
2 files changed, 32 insertions, 2 deletions
diff --git a/dev-ruby/rack-protection/ChangeLog b/dev-ruby/rack-protection/ChangeLog
index 0fcb4a886747..791051815e9a 100644
--- a/dev-ruby/rack-protection/ChangeLog
+++ b/dev-ruby/rack-protection/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rack-protection
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack-protection/ChangeLog,v 1.18 2013/11/21 07:31:46 graaff Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack-protection/ChangeLog,v 1.19 2014/01/16 07:27:37 graaff Exp $
+
+*rack-protection-1.5.2 (16 Jan 2014)
+
+ 16 Jan 2014; Hans de Graaff <graaff@gentoo.org>
+ +rack-protection-1.5.2.ebuild:
+ Version bump.
21 Nov 2013; Hans de Graaff <graaff@gentoo.org> rack-protection-1.5.1.ebuild:
Add ruby20.
diff --git a/dev-ruby/rack-protection/rack-protection-1.5.2.ebuild b/dev-ruby/rack-protection/rack-protection-1.5.2.ebuild
new file mode 100644
index 000000000000..ee6abab83e5a
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-1.5.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack-protection/rack-protection-1.5.2.ebuild,v 1.1 2014/01/16 07:27:37 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="rack-protection.gemspec"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="This gem protects against typical web attacks."
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rack-test )"