summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-11-22 06:38:24 +0000
committerHans de Graaff <graaff@gentoo.org>2012-11-22 06:38:24 +0000
commitacc7e6172816baf201b45416d7f9b128a82af3ff (patch)
treea545115ac9999a6b9a0beffe88be969cd7778c15 /dev-ruby
parentVersion bump (diff)
downloadgentoo-2-acc7e6172816baf201b45416d7f9b128a82af3ff.tar.gz
gentoo-2-acc7e6172816baf201b45416d7f9b128a82af3ff.tar.bz2
gentoo-2-acc7e6172816baf201b45416d7f9b128a82af3ff.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/gnuplot/ChangeLog7
-rw-r--r--dev-ruby/gnuplot/gnuplot-2.6.0.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-ruby/gnuplot/ChangeLog b/dev-ruby/gnuplot/ChangeLog
index 6ca58d852fef..7b0f78cc420a 100644
--- a/dev-ruby/gnuplot/ChangeLog
+++ b/dev-ruby/gnuplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/gnuplot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/ChangeLog,v 1.16 2012/08/06 18:19:05 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/ChangeLog,v 1.17 2012/11/22 06:38:24 graaff Exp $
+
+*gnuplot-2.6.0 (22 Nov 2012)
+
+ 22 Nov 2012; Hans de Graaff <graaff@gentoo.org> +gnuplot-2.6.0.ebuild:
+ Version bump.
*gnuplot-2.5.0 (06 Aug 2012)
diff --git a/dev-ruby/gnuplot/gnuplot-2.6.0.ebuild b/dev-ruby/gnuplot/gnuplot-2.6.0.ebuild
new file mode 100644
index 000000000000..0d6f77a50365
--- /dev/null
+++ b/dev-ruby/gnuplot/gnuplot-2.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/gnuplot-2.6.0.ebuild,v 1.1 2012/11/22 06:38:24 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS.txt ChangeLog README.textile"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Gnuplot drawing library - Ruby Bindings"
+HOMEPAGE="http://rgplot.rubyforge.org/"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+SLOT="0"
+
+RDEPEND="${RDEPEND} sci-visualization/gnuplot"
+
+all_ruby_prepare() {
+ # Existing metadata causes a crash in jruby, so use our own.
+ rm ../metadata || die "Unable to remove metadata."
+}
+
+each_ruby_test() {
+ ${RUBY} -Ctest test_gnuplot.rb || die
+}