summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-06 11:39:41 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-06 11:39:41 +0000
commitbcc7e2c45d3f9c651af4da1886fed6ad4a53620f (patch)
tree48e16a168e25d062cb4c2ba42aae2b88a37558ba /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-bcc7e2c45d3f9c651af4da1886fed6ad4a53620f.tar.gz
gentoo-2-bcc7e2c45d3f9c651af4da1886fed6ad4a53620f.tar.bz2
gentoo-2-bcc7e2c45d3f9c651af4da1886fed6ad4a53620f.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/loquacious/ChangeLog9
-rw-r--r--dev-ruby/loquacious/loquacious-1.9.1-r1.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-ruby/loquacious/ChangeLog b/dev-ruby/loquacious/ChangeLog
index df9f4be55388..a587e87cb57c 100644
--- a/dev-ruby/loquacious/ChangeLog
+++ b/dev-ruby/loquacious/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/loquacious
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/loquacious/ChangeLog,v 1.18 2012/08/26 06:16:06 graaff Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/loquacious/ChangeLog,v 1.19 2013/10/06 11:39:41 mrueg Exp $
+
+*loquacious-1.9.1-r1 (06 Oct 2013)
+
+ 06 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +loquacious-1.9.1-r1.ebuild:
+ Add ruby20 target.
26 Aug 2012; Hans de Graaff <graaff@gentoo.org> -loquacious-1.9.0.ebuild:
Cleanup.
diff --git a/dev-ruby/loquacious/loquacious-1.9.1-r1.ebuild b/dev-ruby/loquacious/loquacious-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..98173149d7ca
--- /dev/null
+++ b/dev-ruby/loquacious/loquacious-1.9.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/loquacious/loquacious-1.9.1-r1.ebuild,v 1.1 2013/10/06 11:39:41 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Descriptive configuration files for Ruby written in Ruby"
+HOMEPAGE="http://github.com/TwP/loquacious"
+
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+all_ruby_prepare() {
+ # Remove metadata because it confuses jruby.
+ rm ../metadata || die
+}
+
+all_ruby_compile() {
+ if use doc; then
+ rdoc lib || die "Documentation generation failed."
+ fi
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}