summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-15 18:45:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-15 18:45:27 +0000
commitc39c31d50704300cb37c67743390874c1f328a8d (patch)
tree6be46777986c881beab40cfbb69173a5d74e03d0 /dev-ruby
parentRemove the test.rb file even if src_test is not executed. (diff)
downloadgentoo-2-c39c31d50704300cb37c67743390874c1f328a8d.tar.gz
gentoo-2-c39c31d50704300cb37c67743390874c1f328a8d.tar.bz2
gentoo-2-c39c31d50704300cb37c67743390874c1f328a8d.zip
Execute test.rb in the src_test phase, but don't install it.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-progressbar/ChangeLog8
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-0.8.ebuild15
2 files changed, 18 insertions, 5 deletions
diff --git a/dev-ruby/ruby-progressbar/ChangeLog b/dev-ruby/ruby-progressbar/ChangeLog
index 000b2f0d69a9..84bebec3c647 100644
--- a/dev-ruby/ruby-progressbar/ChangeLog
+++ b/dev-ruby/ruby-progressbar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ruby-progressbar
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ChangeLog,v 1.15 2006/12/05 22:37:36 jer Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ChangeLog,v 1.16 2008/11/15 18:45:27 flameeyes Exp $
+
+ 15 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org>
+ ruby-progressbar-0.8.ebuild:
+ Execute test.rb in the src_test phase, but don't install it.
05 Dec 2006; Jeroen Roovers <jer@gentoo.org> ruby-progressbar-0.8.ebuild:
Stable for HPPA (bug #156872).
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-0.8.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-0.8.ebuild
index 6bdfeab22331..b02f48d4c042 100644
--- a/dev-ruby/ruby-progressbar/ruby-progressbar-0.8.ebuild
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-0.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ruby-progressbar-0.8.ebuild,v 1.14 2006/12/05 22:37:36 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-progressbar/ruby-progressbar-0.8.ebuild,v 1.15 2008/11/15 18:45:27 flameeyes Exp $
inherit ruby
@@ -10,9 +10,18 @@ SRC_URI="http://namazu.org/~satoru/ruby-progressbar/${P}.tar.gz"
LICENSE="Ruby"
SLOT="0"
-USE_RUBY="any"
+USE_RUBY="ruby18"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
IUSE=""
DEPEND="virtual/ruby"
+
+src_test() {
+ ${RUBY} -I. test.rb || die "test failed"
+}
+
+src_install() {
+ rm test.rb
+ ruby_src_install
+}