summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-07-05 05:56:30 +0000
committerHans de Graaff <graaff@gentoo.org>2015-07-05 05:56:30 +0000
commitf51d4621fe29a83b40092e7ffd151bd442f293a2 (patch)
treeec9a7970a3fed9205b1fafd801448bad15d74975 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-f51d4621fe29a83b40092e7ffd151bd442f293a2.tar.gz
gentoo-2-f51d4621fe29a83b40092e7ffd151bd442f293a2.tar.bz2
gentoo-2-f51d4621fe29a83b40092e7ffd151bd442f293a2.zip
Cleanup.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/date_validator/ChangeLog6
-rw-r--r--dev-ruby/date_validator/date_validator-0.7.0.ebuild47
-rw-r--r--dev-ruby/date_validator/date_validator-0.7.1.ebuild49
3 files changed, 5 insertions, 97 deletions
diff --git a/dev-ruby/date_validator/ChangeLog b/dev-ruby/date_validator/ChangeLog
index 4e85ab918606..c3ffca3bf8a2 100644
--- a/dev-ruby/date_validator/ChangeLog
+++ b/dev-ruby/date_validator/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/date_validator
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/date_validator/ChangeLog,v 1.11 2015/07/05 05:55:19 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/date_validator/ChangeLog,v 1.12 2015/07/05 05:56:30 graaff Exp $
+
+ 05 Jul 2015; Hans de Graaff <graaff@gentoo.org> -date_validator-0.7.0.ebuild,
+ -date_validator-0.7.1.ebuild:
+ Cleanup.
*date_validator-0.8.1 (05 Jul 2015)
diff --git a/dev-ruby/date_validator/date_validator-0.7.0.ebuild b/dev-ruby/date_validator/date_validator-0.7.0.ebuild
deleted file mode 100644
index 0a4475028788..000000000000
--- a/dev-ruby/date_validator/date_validator-0.7.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/date_validator/date_validator-0.7.0.ebuild,v 1.3 2014/08/06 06:41:51 mrueg Exp $
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_EXTRADOC="Readme.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-# if ever needed
-#GITHUB_USER="codegram"
-#GITHUB_PROJECT="${PN}"
-#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Simple, ORM agnostic, Ruby 1.9 compatible date validator for Rails 3"
-HOMEPAGE="http://github.com/codegram/date_validator"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/activemodel-3.0
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/minitest
- >=dev-ruby/tzinfo-0.3
- >=dev-ruby/activesupport-3.0
- )
- doc? ( dev-ruby/yard )"
-
-all_ruby_prepare() {
- sed -i \
- -e '/git ls-files/d' \
- ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i \
- -e '/[Bb]undler/s/^/#/' Rakefile || die
-}
diff --git a/dev-ruby/date_validator/date_validator-0.7.1.ebuild b/dev-ruby/date_validator/date_validator-0.7.1.ebuild
deleted file mode 100644
index 1c536e4d2d5c..000000000000
--- a/dev-ruby/date_validator/date_validator-0.7.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/date_validator/date_validator-0.7.1.ebuild,v 1.1 2014/10/22 12:50:11 mrueg Exp $
-
-EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_EXTRADOC="Readme.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-# if ever needed
-#GITHUB_USER="codegram"
-#GITHUB_PROJECT="${PN}"
-#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Simple, ORM agnostic, Ruby 1.9 compatible date validator for Rails 3"
-HOMEPAGE="http://github.com/codegram/date_validator"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/activemodel-3.0
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/minitest
- >=dev-ruby/tzinfo-0.3
- >=dev-ruby/activesupport-3.0
- )
- doc? ( dev-ruby/yard )"
-
-all_ruby_prepare() {
- sed -i \
- -e '/git ls-files/d' \
- ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i \
- -e '/[Bb]undler/s/^/#/' Rakefile || die
- # Fix tests
- sed -i -e "1irequire 'active_support'" test/test_helper.rb || die
-}