summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-04-04 22:28:40 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-04-04 22:28:40 +0000
commitc89d2fe53816f948c59ef0eb4e160cd6262beccf (patch)
tree03f96ebffac2c046d21535da7bd53c8ec2c57a89 /dev-tcltk/snack/snack-2.2.4.ebuild
parentver bump (diff)
downloadgentoo-2-c89d2fe53816f948c59ef0eb4e160cd6262beccf.tar.gz
gentoo-2-c89d2fe53816f948c59ef0eb4e160cd6262beccf.tar.bz2
gentoo-2-c89d2fe53816f948c59ef0eb4e160cd6262beccf.zip
Version bump and some major clean up.
Diffstat (limited to 'dev-tcltk/snack/snack-2.2.4.ebuild')
-rw-r--r--dev-tcltk/snack/snack-2.2.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-tcltk/snack/snack-2.2.4.ebuild b/dev-tcltk/snack/snack-2.2.4.ebuild
new file mode 100644
index 000000000000..453e3de9f2e8
--- /dev/null
+++ b/dev-tcltk/snack/snack-2.2.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/snack/snack-2.2.4.ebuild,v 1.1 2004/04/04 22:28:40 zx Exp $
+
+IUSE="alsa oggvorbis"
+
+DESCRIPTION="The Snack Sound Toolkit (Tcl)"
+HOMEPAGE="http://www.speech.kth.se/snack/"
+SRC_URI="http://www.speech.kth.se/~kare/${PN}${PV}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~x86"
+SLOT="0"
+
+DEPEND=">dev-lang/tcl-8.4.3
+ >dev-lang/tk-8.4.3
+ oggvorbis? ( media-libs/libogg )"
+
+S=${WORKDIR}/${PN}${PV}/unix
+
+src_compile() {
+ local myconf="--enable-threads"
+
+ use alsa && myconf="${myconf} --enable-alsa"
+
+ use oggvorbis && myconf="${myconf} --enable-ogg"
+
+ econf ${myconf} || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D}usr install || die "make install failed"
+ cd ..
+ dodoc BSD.txt COPYING README changes
+ dohtml doc/*
+}