summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-06-07 17:42:25 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-06-07 17:42:25 +0000
commit83e0bbf2e7d090a65ea798f2841c2c34049cbc7b (patch)
tree23b32490b2cf88e96dbce797794ca644534eb3f2 /dev-tcltk
parentAdd ~arm/~s390 (diff)
downloadgentoo-2-83e0bbf2e7d090a65ea798f2841c2c34049cbc7b.tar.gz
gentoo-2-83e0bbf2e7d090a65ea798f2841c2c34049cbc7b.tar.bz2
gentoo-2-83e0bbf2e7d090a65ea798f2841c2c34049cbc7b.zip
fix implicit missing declarations for 5.43.0 too
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/expect/ChangeLog6
-rw-r--r--dev-tcltk/expect/expect-5.43.0.ebuild7
-rw-r--r--dev-tcltk/expect/files/expect-5.43.0-missing-includes.patch44
3 files changed, 54 insertions, 3 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 54032170fe36..55fbcfd286d1 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/expect
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.54 2009/06/07 17:29:26 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.55 2009/06/07 17:42:25 mescalinum Exp $
+
+ 07 Jun 2009; Federico Ferri <mescalinum@gentoo.org>
+ +files/expect-5.43.0-missing-includes.patch, expect-5.43.0.ebuild:
+ fix implicit missing declarations for 5.43.0 too
07 Jun 2009; Federico Ferri <mescalinum@gentoo.org> -expect-5.44.1.ebuild:
version 5.44* recalled by upstream
diff --git a/dev-tcltk/expect/expect-5.43.0.ebuild b/dev-tcltk/expect/expect-5.43.0.ebuild
index d2038679471a..110d9ca45215 100644
--- a/dev-tcltk/expect/expect-5.43.0.ebuild
+++ b/dev-tcltk/expect/expect-5.43.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0.ebuild,v 1.10 2008/12/08 14:08:02 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0.ebuild,v 1.11 2009/06/07 17:42:25 mescalinum Exp $
WANT_AUTOCONF="2.1"
inherit autotools eutils
@@ -48,6 +48,9 @@ src_unpack() {
sed -i -e 's/^\(#include <stdio\.h>\)/\1\n#include "expect_cf.h"/' \
Dbg.c
+ # fix implicit missing declarations (bug 204878)
+ epatch "${FILESDIR}"/"${P}"-missing-includes.patch
+
eautoconf
}
diff --git a/dev-tcltk/expect/files/expect-5.43.0-missing-includes.patch b/dev-tcltk/expect/files/expect-5.43.0-missing-includes.patch
new file mode 100644
index 000000000000..a4310d011216
--- /dev/null
+++ b/dev-tcltk/expect/files/expect-5.43.0-missing-includes.patch
@@ -0,0 +1,44 @@
+diff -urpN expect-5.43.0.orig/work/expect-5.43/exp_glob.c expect-5.43.0/work/expect-5.43/exp_glob.c
+--- expect-5.43.0.orig/work/expect-5.43/exp_glob.c 2009-06-07 19:36:31.000000000 +0200
++++ expect-5.43.0/work/expect-5.43/exp_glob.c 2009-06-07 19:39:04.000000000 +0200
+@@ -11,6 +11,7 @@ would appreciate credit if this program
+
+ */
+
++#include <string.h>
+ #include "expect_cf.h"
+ #include "tcl.h"
+ #include "exp_int.h"
+diff -urpN expect-5.43.0.orig/work/expect-5.43/exp_main_exp.c expect-5.43.0/work/expect-5.43/exp_main_exp.c
+--- expect-5.43.0.orig/work/expect-5.43/exp_main_exp.c 2009-06-07 19:36:31.000000000 +0200
++++ expect-5.43.0/work/expect-5.43/exp_main_exp.c 2009-06-07 19:37:39.000000000 +0200
+@@ -9,6 +9,7 @@ would appreciate credit if this program
+
+ #include "expect_cf.h"
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "tcl.h"
+ #include "expect_tcl.h"
+
+diff -urpN expect-5.43.0.orig/work/expect-5.43/exp_trap.c expect-5.43.0/work/expect-5.43/exp_trap.c
+--- expect-5.43.0.orig/work/expect-5.43/exp_trap.c 2009-06-07 19:36:31.000000000 +0200
++++ expect-5.43.0/work/expect-5.43/exp_trap.c 2009-06-07 19:38:51.000000000 +0200
+@@ -11,6 +11,7 @@ would appreciate credit if this program
+ #include "expect_cf.h"
+
+ #include <stdio.h>
++#include <string.h>
+ #include <signal.h>
+ #include <sys/types.h>
+
+diff -urpN expect-5.43.0.orig/work/expect-5.43/pty_termios.c expect-5.43.0/work/expect-5.43/pty_termios.c
+--- expect-5.43.0.orig/work/expect-5.43/pty_termios.c 2009-06-07 19:36:31.000000000 +0200
++++ expect-5.43.0/work/expect-5.43/pty_termios.c 2009-06-07 19:38:19.000000000 +0200
+@@ -8,6 +8,7 @@ would appreciate credit if you use this
+ */
+
+ #include <stdio.h>
++#include <string.h>
+ #include <signal.h>
+
+ #if defined(SIGCLD) && !defined(SIGCHLD)