summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-17 22:56:19 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-17 22:56:19 +0000
commitdcc9f8d549c610fe766d76b97a77f554ddc7a3eb (patch)
treea9ec03c49aa98359e0f8563ab5e5dc6a662af8c4 /dev-tcltk
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-dcc9f8d549c610fe766d76b97a77f554ddc7a3eb.tar.gz
gentoo-2-dcc9f8d549c610fe766d76b97a77f554ddc7a3eb.tar.bz2
gentoo-2-dcc9f8d549c610fe766d76b97a77f554ddc7a3eb.zip
Fix expectk handling, and include a few more headers #279335 by OKUMURA N. Shin-ya.
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/expect/ChangeLog8
-rw-r--r--dev-tcltk/expect/expect-5.44.1.15.ebuild3
-rw-r--r--dev-tcltk/expect/files/expect-5.44.1.15-expectk.patch14
-rw-r--r--dev-tcltk/expect/files/expect-5.44.1.15-headers.patch10
4 files changed, 33 insertions, 2 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 42e58a5b8077..fe8112bd9769 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/expect
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.83 2010/12/17 22:35:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.84 2010/12/17 22:56:19 vapier Exp $
+
+ 17 Dec 2010; Mike Frysinger <vapier@gentoo.org> expect-5.44.1.15.ebuild,
+ +files/expect-5.44.1.15-expectk.patch,
+ files/expect-5.44.1.15-headers.patch:
+ Fix expectk handling, and include a few more headers #279335 by OKUMURA N.
+ Shin-ya.
17 Dec 2010; Mike Frysinger <vapier@gentoo.org> expect-5.44.1.15.ebuild:
Force ignoring of -w in MAKEOPTS #338970 by Drake Wyrm.
diff --git a/dev-tcltk/expect/expect-5.44.1.15.ebuild b/dev-tcltk/expect/expect-5.44.1.15.ebuild
index adcb65cab2d5..006a65b115c9 100644
--- a/dev-tcltk/expect/expect-5.44.1.15.ebuild
+++ b/dev-tcltk/expect/expect-5.44.1.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.44.1.15.ebuild,v 1.15 2010/12/17 22:35:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.44.1.15.ebuild,v 1.16 2010/12/17 22:56:19 vapier Exp $
EAPI="3"
@@ -33,6 +33,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-ldflags.patch
epatch "${FILESDIR}"/${P}_with-tk-no.patch
epatch "${FILESDIR}"/${P}-headers.patch #337943
+ epatch "${FILESDIR}"/${P}-expectk.patch
sed -i 's:ifdef HAVE_SYS_WAIT_H:ifndef NO_SYS_WAIT_H:' *.c
eautoconf
diff --git a/dev-tcltk/expect/files/expect-5.44.1.15-expectk.patch b/dev-tcltk/expect/files/expect-5.44.1.15-expectk.patch
new file mode 100644
index 000000000000..0c0ba80293e0
--- /dev/null
+++ b/dev-tcltk/expect/files/expect-5.44.1.15-expectk.patch
@@ -0,0 +1,14 @@
+expectk is only built when TK_BIN_DIR is defined. the configure script
+takes care of figuring out this value, but then they forgot to actually
+write it out to the Makefile.
+
+--- Makefile.in
++++ Makefile.in
+@@ -24,6 +24,7 @@
+ # SETUID = chmod u+s
+
+ LIB_RUNTIME_DIR = $(DESTDIR)@libdir@
++TK_BIN_DIR = @TK_BIN_DIR@
+
+ # The following Expect scripts are not necessary to have installed as
+ # commands, but are very useful. Edit out what you don't want
diff --git a/dev-tcltk/expect/files/expect-5.44.1.15-headers.patch b/dev-tcltk/expect/files/expect-5.44.1.15-headers.patch
index 33253bf381cc..77e4d91f4bf9 100644
--- a/dev-tcltk/expect/files/expect-5.44.1.15-headers.patch
+++ b/dev-tcltk/expect/files/expect-5.44.1.15-headers.patch
@@ -74,3 +74,13 @@ https://sourceforge.net/tracker/?func=detail&aid=3071706&group_id=13179&atid=113
void exp_tty_break(Tcl_Interp *interp, int fd);
int exp_tty_raw_noecho(Tcl_Interp *interp, exp_tty *tty_old, int *was_raw, int *was_echo);
int exp_israw(void);
+--- a/exp_main_tk.c
++++ b/exp_main_tk.c
+@@ -32,6 +32,7 @@
+ static char sccsid[] = "@(#) tkAppInit.c 1.19 95/12/23 17:09:24";
+ #endif /* not lint */
+
++#include <string.h>
+ #include <ctype.h>
+
+ #include "tk.h"