summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-05-10 07:52:11 +0000
committerTim Harder <radhermit@gentoo.org>2012-05-10 07:52:11 +0000
commit1553583d5596904c95ab0fc22a7e0c060e787e8e (patch)
tree3faf6a2ce8c3d5b3ae55a01ac2adae68bf2da7a5 /dev-tex/latexmk/latexmk-431.ebuild
parentStable for X86, wrt bug #415323 (diff)
downloadgentoo-2-1553583d5596904c95ab0fc22a7e0c060e787e8e.tar.gz
gentoo-2-1553583d5596904c95ab0fc22a7e0c060e787e8e.tar.bz2
gentoo-2-1553583d5596904c95ab0fc22a7e0c060e787e8e.zip
Version bump.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-tex/latexmk/latexmk-431.ebuild')
-rw-r--r--dev-tex/latexmk/latexmk-431.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-tex/latexmk/latexmk-431.ebuild b/dev-tex/latexmk/latexmk-431.ebuild
new file mode 100644
index 000000000000..0ef3e7d1da17
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-431.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/latexmk/latexmk-431.ebuild,v 1.1 2012/05/10 07:52:11 radhermit Exp $
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents."
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin latexmk.pl latexmk
+ doman latexmk.1
+ dodoc CHANGES README latexmk.pdf latexmk.ps latexmk.txt
+ dodoc -r example_rcfiles extra-scripts
+ newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}