summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2013-11-19 16:34:00 +0000
committerDenis Dupeyron <calchan@gentoo.org>2013-11-19 16:34:00 +0000
commita9bdf5e320c855aa97ce64eee4d39431e766a951 (patch)
treece090f9ba7ac82d37ff38e86138f2bc5a0bce1e6 /dev-tex
parentStable for HPPA (bug #491588). (diff)
downloadgentoo-2-a9bdf5e320c855aa97ce64eee4d39431e766a951.tar.gz
gentoo-2-a9bdf5e320c855aa97ce64eee4d39431e766a951.tar.bz2
gentoo-2-a9bdf5e320c855aa97ce64eee4d39431e766a951.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/circuit_macros/ChangeLog8
-rw-r--r--dev-tex/circuit_macros/circuit_macros-7.7.1.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-tex/circuit_macros/ChangeLog b/dev-tex/circuit_macros/ChangeLog
index 0cd0e5ce5f3d..f921e44f0601 100644
--- a/dev-tex/circuit_macros/ChangeLog
+++ b/dev-tex/circuit_macros/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tex/circuit_macros
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/circuit_macros/ChangeLog,v 1.5 2013/11/04 19:38:28 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/circuit_macros/ChangeLog,v 1.6 2013/11/19 16:34:00 calchan Exp $
+
+*circuit_macros-7.7.1 (19 Nov 2013)
+
+ 19 Nov 2013; Denis Dupeyron <calchan@gentoo.org>
+ +circuit_macros-7.7.1.ebuild:
+ Version bump.
04 Nov 2013; Denis Dupeyron <calchan@gentoo.org> -circuit_macros-7.5.ebuild,
-circuit_macros-7.6.ebuild, -circuit_macros-7.7.ebuild, -files/CM2pdf:
diff --git a/dev-tex/circuit_macros/circuit_macros-7.7.1.ebuild b/dev-tex/circuit_macros/circuit_macros-7.7.1.ebuild
new file mode 100644
index 000000000000..12ea05a39cea
--- /dev/null
+++ b/dev-tex/circuit_macros/circuit_macros-7.7.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/circuit_macros/circuit_macros-7.7.1.ebuild,v 1.1 2013/11/19 16:34:00 calchan Exp $
+
+EAPI=5
+
+inherit unpacker texlive-common
+
+DESCRIPTION="M4 Macros for Electric circuit diagrams in TeX or LaTeX"
+HOMEPAGE="https://ece.uwaterloo.ca/~aplevich/Circuit_macros/"
+SRC_URI="http://mirrors.ctan.org/graphics/circuit_macros.zip -> circuit_macros-${PV}.zip"
+
+LICENSE="LPPL-1.3c"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +script"
+
+DEPEND=""
+RDEPEND="|| ( app-text/texlive[graphics] app-text/texlive[pstricks] )
+ media-gfx/dpic
+ sys-devel/m4
+ script? ( app-text/texlive[graphics]
+ dev-texlive/texlive-latexextra )"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins *.m4
+ insinto /usr/share/texmf-site/tex/latex/${PN}
+ doins boxdims.sty
+ dodoc README CHANGES Makefile doc/CMman.pdf
+ rm -f doc/CMman.pdf
+ use doc && dodoc -r doc
+ use examples && dodoc -r examples
+ use script && dobin "${FILESDIR}/cm2pdf"
+ docompress -x \
+ /usr/share/doc/${PF}/Makefile \
+ /usr/share/doc/${PF}/doc \
+ /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ etexmf-update
+ use script && einfo "cm2pdf was installed to automatically create PDFs. Run cm2pdf --help for usage help."
+}
+
+pkg_postrm() {
+ etexmf-update
+}