summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSandro Bonazzola <sanchan@gentoo.org>2006-12-04 21:41:00 +0000
committerSandro Bonazzola <sanchan@gentoo.org>2006-12-04 21:41:00 +0000
commit3358890286bc3a36f40dbf4ccbcad4976bf8f4c4 (patch)
tree9a45b0b40bc7d5d9b6bb89e515867218b966e9f9 /dev-tinyos
parentremove unused media-video/dvdrip:rar use flag (diff)
downloadgentoo-2-3358890286bc3a36f40dbf4ccbcad4976bf8f4c4.tar.gz
gentoo-2-3358890286bc3a36f40dbf4ccbcad4976bf8f4c4.tar.bz2
gentoo-2-3358890286bc3a36f40dbf4ccbcad4976bf8f4c4.zip
Version bumped (bug #156856). It includes upstream bug fix for bug #145870. Thanks to Aurélien for the report and testing.
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'dev-tinyos')
-rw-r--r--dev-tinyos/nesc/ChangeLog8
-rw-r--r--dev-tinyos/nesc/files/digest-nesc-1.2.83
-rw-r--r--dev-tinyos/nesc/nesc-1.2.8.ebuild84
3 files changed, 94 insertions, 1 deletions
diff --git a/dev-tinyos/nesc/ChangeLog b/dev-tinyos/nesc/ChangeLog
index 78bf3b3bfe1f..cb3dd5756540 100644
--- a/dev-tinyos/nesc/ChangeLog
+++ b/dev-tinyos/nesc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tinyos/nesc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/ChangeLog,v 1.12 2006/11/14 21:32:58 sanchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/ChangeLog,v 1.13 2006/12/04 21:41:00 sanchan Exp $
+
+*nesc-1.2.8 (04 Dec 2006)
+
+ 04 Dec 2006; Sandro Bonazzola <sanchan@gentoo.org> +nesc-1.2.8.ebuild:
+ Version bumped (bug #156856). It includes upstream bug fix for bug #145870.
+ Thanks to Aurélien for the report and testing.
14 Nov 2006; Sandro Bonazzola <sanchan@gentoo.org>
+files/nesc-1.2.7a-alignment.patch, -nesc-1.2.4-r1.ebuild,
diff --git a/dev-tinyos/nesc/files/digest-nesc-1.2.8 b/dev-tinyos/nesc/files/digest-nesc-1.2.8
new file mode 100644
index 000000000000..7ec0b0663117
--- /dev/null
+++ b/dev-tinyos/nesc/files/digest-nesc-1.2.8
@@ -0,0 +1,3 @@
+MD5 dafaa93d87a608a654914f5e410a31a7 nesc-1.2.8.tar.gz 1164224
+RMD160 cdd01ec767be7df5ca2498995b9046c53d79d3af nesc-1.2.8.tar.gz 1164224
+SHA256 b00acea4728943ae4cce83df0e1e819e88ad0a577e617757c8362ac46df6b03d nesc-1.2.8.tar.gz 1164224
diff --git a/dev-tinyos/nesc/nesc-1.2.8.ebuild b/dev-tinyos/nesc/nesc-1.2.8.ebuild
new file mode 100644
index 000000000000..0a020a26eb50
--- /dev/null
+++ b/dev-tinyos/nesc/nesc-1.2.8.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/nesc/nesc-1.2.8.ebuild,v 1.1 2006/12/04 21:41:00 sanchan Exp $
+
+inherit eutils java-pkg-2
+
+DESCRIPTION="An extension to gcc that knows how to compile nesC applications"
+HOMEPAGE="http://nescc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nescc/${P}.tar.gz"
+LICENSE="GPL-2 Intel"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+DEPEND=">=dev-lang/perl-5.8.5-r2
+ >=dev-tinyos/tos-1.1.0
+ >=virtual/jdk-1.4.2"
+
+RDEPEND=">=dev-lang/perl-5.8.5-r2
+ >=dev-tinyos/tos-1.1.0
+ >=virtual/jre-1.4.2
+ dev-perl/XML-Simple
+ media-gfx/graphviz"
+
+pkg_setup() {
+ if [ -z "${TOSDIR}" ]
+ then
+ # best to make an assumption
+ export TOSDIR=/usr/src/tinyos-1.x/tos
+ fi
+
+ if [ ! -d "${TOSDIR}" ]
+ then
+ eerror "In order to compile nesc you have to set the"
+ eerror "\$TOSDIR environment properly."
+ eerror ""
+ eerror "You can achieve this by emerging >=dev-tinyos/tos-1.1.15"
+ eerror "or by exporting TOSDIR=\"path to your tinyos dir\""
+ die "Couldn't find a valid TinyOS home"
+ else
+ einfo "Building nesC for ${TOSDIR}"
+ fi
+
+ java-pkg-2_pkg_setup
+}
+
+src_compile() {
+ econf --disable-dependency-tracking || die "econf failed"
+ # language setting needed, otherwise gcc version
+ # will sometimes not be detected right
+ LANGUAGE=C emake || die "emake failed"
+}
+
+src_install() {
+ LANGUAGE=C einstall || die "einstall failed"
+
+ if use doc
+ then
+ dohtml -r -a html,jpg,pdf,txt doc/*
+ fi
+
+ newdoc README NEWS
+ newdoc tools/java/net/tinyos/nesc/dump/README README.dump
+ newdoc tools/java/net/tinyos/nesc/wiring/README README.wiring
+}
+
+pkg_postinst() {
+ elog "To install a nesC editor mode (currently, emacs, vim, kde):"
+ elog "Read /usr/share/ncc/editor-modes/<your-editor-name>/readme.txt"
+ elog ""
+ elog "To use nesC with the Atmel AVR processors or the TI MSP processors you"
+ elog "need the avr-gcc and msp430-gcc packages, and the corresponding GNU"
+ elog "binutils (avr-binutils and msp430-binutils respectively)."
+ elog "# emerge crossdev"
+ elog "# crossdev -t avr"
+ elog "# crossdev -t msp430"
+ elog ""
+ elog "You can use gcc <= 3.4.6 and binutils <= 2.16.1-r3 if you need $ in"
+ elog "symbol names on avr or you can pass the -fnesc-separator=__ option to"
+ elog "nescc (ncc if using TinyOS) to use __ rather than $ in generated code."
+ elog "Example: PFLAGS=\"-fnesc-separator=__\" make mica2"
+ elog "See the nescc man page for details."
+ ebeep 5
+ epause 5
+}