summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-10-31 00:39:29 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-10-31 00:39:29 +0000
commit7cc412047b235b2e96cd43790c2925aa3db7abc3 (patch)
treec78a17bb63f3829464d23c4b4bcc3e0437f23029 /dev-util/argouml
parentVersion bump (diff)
downloadgentoo-2-7cc412047b235b2e96cd43790c2925aa3db7abc3.tar.gz
gentoo-2-7cc412047b235b2e96cd43790c2925aa3db7abc3.tar.bz2
gentoo-2-7cc412047b235b2e96cd43790c2925aa3db7abc3.zip
Updated to current upstream release, with minor src path changes.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26.5 x86_64)
Diffstat (limited to 'dev-util/argouml')
-rw-r--r--dev-util/argouml/ChangeLog7
-rw-r--r--dev-util/argouml/argouml-0.26.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-util/argouml/ChangeLog b/dev-util/argouml/ChangeLog
index 62ee689ea7be..98ac916b52e0 100644
--- a/dev-util/argouml/ChangeLog
+++ b/dev-util/argouml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/argouml
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/argouml/ChangeLog,v 1.23 2008/08/30 14:33:07 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/argouml/ChangeLog,v 1.24 2008/10/31 00:39:29 nerdboy Exp $
+
+*argouml-0.26 (31 Oct 2008)
+
+ 31 Oct 2008; Steve Arnold <nerdboy@gentoo.org> +argouml-0.26.ebuild:
+ Updated to current upstream release, with minor src path changes...
30 Aug 2008; Brent Baude <ranger@gentoo.org> argouml-0.24.ebuild:
stable ppc, bug 235280
diff --git a/dev-util/argouml/argouml-0.26.ebuild b/dev-util/argouml/argouml-0.26.ebuild
new file mode 100644
index 000000000000..54aacdceca3a
--- /dev/null
+++ b/dev-util/argouml/argouml-0.26.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/argouml/argouml-0.26.ebuild,v 1.1 2008/10/31 00:39:29 nerdboy Exp $
+
+inherit java-pkg-2
+
+DESCRIPTION="modelling tool that helps you do your design using UML"
+HOMEPAGE="http://argouml.tigris.org"
+BASE_URI="http://argouml-downloads.tigris.org/nonav/${P}"
+SRC_URI="${BASE_URI}/ArgoUML-${PV}.tar.gz
+ http://argouml-downloads.tigris.org/nonav/argouml-db-1.0/dbuml-module-1.0.4.zip
+ doc? (
+ ${BASE_URI}/argomanual-${PV}.pdf
+ ${BASE_URI}/quickguide-${PV}.pdf
+ ${BASE_URI}/cookbook-${PV}.pdf
+ )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}"
+
+src_compile() { :; }
+
+src_install() {
+ java-pkg_jarinto /opt/${PN}/lib
+ java-pkg_dojar ${P}/*.jar
+
+ java-pkg_jarinto /opt/${PN}/lib/ext
+ java-pkg_dojar ${P}/ext/*.jar release/ext/*.jar
+
+ java-pkg_dolauncher ${PN} --main org.argouml.application.Main
+
+ dodoc ${P}/README.txt
+
+ if use doc ; then
+ dohtml -r release/{Readme.htm,www}
+ insinto /usr/share/doc/${P}
+ doins "${DISTDIR}/argomanual-${PV}.pdf"
+ doins "${DISTDIR}/quickguide-${PV}.pdf"
+ doins "${DISTDIR}/cookbook-${PV}.pdf"
+ fi
+}
+